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Quick Step Guide to E-mail PM EFT Remittances in Microsoft Dynamics GP 2013


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Symptoms

How to get the E-mail functionality to work for Payables EFT Remittances using Word Templates in Microsoft Dynamics GP 2013.


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Cause

PREREQUISITES:

•Supported versions of Microsoft Office:

          •Microsoft Office 2010 - 64-bit Office must use Exchange only.  32-bit Office can use either Exchange or  MAPI.

          •Microsoft Office 2013 -  64-bit Office must use Exchange only.  32-bit Office can use either Exchange or  MAPI.

          •Office 365 - Both 64-bit or 32-bit must use Exchange.  (For an Online Exchange Server there typically isn't a MAPI client installed.)

•Verify in the Control Panel | Programs and Features that the 'Open XML SDK 2.0 for Microsoft Office'is installed.  (Required)

•The 'Microsoft Dynamics GP Add-in for Microsoft Word'is only needed if you will be modifying the Word Template.  (Optional)
NOTE:  If you have Mekorma MICR installed, make sure the Mekorma MICR System Options are set to have email enabled, or else the "Send Document in email' checkbox in the Remittance window will not be available to mark (or grayed out).  To check this setting, go to Microsoft Dynamics GP | Tools | Setup | System | Mekorma MICR | System Options.  Mark the checkbox for 'Enable Email Remittance' and click Save

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Resolution

STEPS:

Step 1.  For the sake of testing, it is recommended to first get the email functionality working by using the original canned Check Remittance in your initial testing.  This is important to verify the email functionality is working and to rule out any issues that may be due to an incomplete or damaged modified Word Template.  Use these steps to check the security settings:

     a.  Go to Microsoft Dynamics GP | Tools | Setup | System | Alternate/Modified Forms and Reports. and select the REPORT ID being used.  (Ex. DEFAULTUSER)

     b.  Leave Product as All Products.  For Type, select Reports.  For Series, leave as All or select Purchasing.

     c.  In the Report List, click to expand Purchasing.

     d.  Scroll down to the Check Remittance and make sure Microsoft Dynamics GP is marked.   (If it is not listed, then you do not have a modified check remittance in the system.) Click Save.

 

Step 2. Activate the E-mail functionality for the Check Remittance at the main setup level by using the following steps:

     a.  Go to Microsoft Dynamics GP | Tools | Setup | Company | E-mail Settings.

     b.  Mark the Document Options and File Formats you want to allow.  (This creates the pick-list you see at the vendor level so you can customize per vendor.)

     c.  Click on the PurchasingSeries link and mark the checkbox for Vendor Remittance. (Keep it simple as possible for testing.  Don't use a Message ID yet.)  Click OK.  Click OK again to close the window.



Step 3.  Complete the setup for each Vendor by using these steps:

    a.  Go to Cards | Purchasing | Vendor.  Select the Vendor ID that you want to send the EFT remittance to.

    b.  Next to the Address ID field, click on the 'World' button to open the Internet Information window.  For testing, enter your own email address in the TO: section for E-Mail Addresses at the top.  (Once it is working, you can edit it later to be the vendor's email address.)  Click Save and close the Internet Information window.

    c.  On the Vendor Maintenance window, click the E-mail button.  In the bottom section, mark the checkbox for Vendor Remittance and choose which Format to use.  (We recommend to test with .docx or .html first just to get it working.)  Click OK and then click Save.



Step 4.  Presumably, there are already posted invoices keyed against the EFT Address ID for this vendor ready to be paid out. During the Payables checkrun process:

 a. Outlook must be open on the same workstation that Dynamics GP 2013 is on.

 b. Build a computer check batch and select EFT as the Payment Method for the new batch.

 c. When you click to print checks, you will get a Process Payables Remittance window instead of a Print Checks window, since it is an EFT and not a check.  Mark the radio box for Remittance Form, and also mark the checkbox for Send Document in E-mail (Print if mail cannot be sent.).  Click Process.

 d.  In the Report Destination window, the Report Type of Template will default if a Word Template is being used.  Complete and post the checkrun.  

 e.  The Send Remittance Exception Report will display and hopefully each says Document sent successfully.  Review the report for any emails that did not sent successfully.



Step 5.  Go to Outlook to verify that you received the test email.  Check the Sent Items folder in Outlook to verify that the emails went out.  (They could still be in the Outbox too, so make sure they are not stuck there due to Outlook settings.)

If these steps don't work for you, open a support incident or refer to the Report Writer manual for more information on using Word Template functionality.  If you have questions on how to modify the Word Template, refer to the Report Writer manual or open a support case.  Please note that the assistance we will provide with Word Template modifications is outlined in Knowledge Base (KB) # 850201.  Anything beyond what is outlined in this KB article may be considered a consulting expense, and beyond what we can do in a regular support case.  Please refer to our policy outlined below:

850201 Guidelines that Microsoft support professionals use to determine when a support case becomes a consulting engagement for Report Writer, SSRS, Word Templates, SmartList Builder, SQL scripts, Business Alerts, VB Script, Modifier/VBA and Configurator Files
https://mbs.microsoft.com/knowledgebase/KBDisplay.aspx?scid=kb;EN-US;850201



Step 6.  If the test above worked successfully, then continue to grant security access to the modified Check Remittance and test again.


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Article Info
Article ID : 2998439
Revision : 2
Created on : 3/8/2018
Published on : 3/8/2018
Exists online : False
Views : 183