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NTFS file system freezes on a data deduplication volume in Windows Server 2012 R2


View products that this article applies to.

Symptoms

Issue 1
On a computer that is running Windows Server 2012 R2, the server may crash, and you receive the following error:

Bug Check 0x0000009E

Issue 2
New Technology File System (NTFS) or Network File System (NFS) service freezes on a data deduplication-enabled volume.

Issue 3
Access to NFS shares that are mounted on a data deduplication-enabled volume is frozen.

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Cause

These issues occur because data deduplication requires more space. If the requested space is not allocated, a recursive call (Ntfs!NtfsWriteUsnJournalChanges) occurs, followed by a deadlock.

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Resolution

To resolve this issue, we have released an update rollup and a hotfix for Windows 8.1 or Windows Server 2012 R2.
Shall I choose hotfix or update rollup?
The update rollup fixes many other issues in addition to the issue that the hotfix fixes. We recommend that you use the update rollup. The update rollup is larger than the hotfix. Therefore, the update rollup takes longer to download.

Get the update rollup for Windows Server 2012 R2

To resolve this issue, install the update rollup that is dated November 2014.

Get the November 2014 update rollup for Windows RT 8.1, Windows 8.1, or Windows Server 2012 R2

Get the hotfix for Windows Server 2012 R2

A supported hotfix is available from Microsoft Support. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, go to the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, a hotfix is not available for that language.

Prerequisites

To apply this update, you must first have update 2919355  installed in Windows Server 2012 R2.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any previously released hotfix.

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File information
The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.

Windows Server 2012 R2 file information and notes

Important Windows 8.1 and Windows Server 2012 R2 hotfixes are included in the same packages. However, only "Windows 8.1" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 8.1" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.

    VersionProductMilestoneService branch
    6.3.960 0.17 xxxWindows Server 2012 R2RTMGDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows 8.1 and Windows Server 2012 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2012 R2
File nameFile versionFile sizeDateTimePlatform
Ntfs.sys6.3.9600.173292,028,86429-Aug-201408:06x64

Additional file information for Windows Server 2012 R2

Additional files for all supported x64-based versions of Windows Server 2012 R2
File propertyValue
File nameAmd64_76d89afee31fda04ddec1835d8d2994d_31bf3856ad364e35_6.3.9600.17329_none_2b8e6b2f7ed02608.manifest
File versionNot applicable
File size696
Date (UTC)29-Aug-2014
Time (UTC)19:50
File nameAmd64_microsoft-windows-ntfs_31bf3856ad364e35_6.3.9600.17329_none_977553f9f0ad90b5.manifest
File versionNot applicable
File size16,011
Date (UTC)29-Aug-2014
Time (UTC)08:17

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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References

Learn about the terminology that Microsoft uses to describe software updates.

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Keywords: kb, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbexpertiseinter, kbsurveynew, kbbug

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Article Info
Article ID : 2996903
Revision : 2
Created on : 6/12/2017
Published on : 6/12/2017
Exists online : False
Views : 197