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Logging feature in Lync Web App doesn't work after passive authentication is enabled by using ADFS in Lync Server 2013


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Symptoms

Consider the following scenario:
  • You deploy Active Directory Federation Services (ADFS) in a Microsoft Lync Server 2013 environment.
  • You set passive authentication (PA) for web service by using ADFS. To do this, you run the following command in Microsoft PowerShell:
    Set-CsWebServiceConfiguration -UseWindowsAuth None -UseWsFedPassiveAuth $true -WsFedPassiveMetadataUri %MetadataURI% 
  • A user creates a Lync meeting request by using Lync Web Scheduler. 
  • The user pastes the meeting request that contains the meeting URI that has the "?sl=1$log=full" string at the end of it into Internet Explorer.
  • The user joins the meeting.
  • The user exits the meeting and then signs out from Lync Web App.
In this scenario, the logging feature in Lync Web App does not work, and log files are not generated in the following path:

C:\Users\<username>\AppData\Local\Microsoft\LWAPlugin\Tracing\ LWAJSPersistent<x>.log

Note The <x> value is a number, such as 0 or 1.

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Cause

This issue occurs because Lync Web App checks the passive authentication flag for the logging by using invalid logic.

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Resolution

To resolve this issue, install the following update:
2995718 September 2014 Cumulative Update 5.0.8308.815 for Lync Server 2013, web components server

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Keywords: kbqfe, kbfix, kbsurveynew, kbexpertiseinter, kb

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Article Info
Article ID : 2995825
Revision : 1
Created on : 1/7/2017
Published on : 9/23/2014
Exists online : False
Views : 162