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"Device does not exist" error after you reinsert a USB COM port device


View products that this article applies to.

Symptoms

USB devices that expose COM ports for communicating between their application and the device use the inbox Usbser.sys to create virtual COM ports in Windows 8.1, Windows Server 2012 R2, Windows 7, or Windows Server 2008 R2. If such a device is removed and then reinserted quickly, it may not be rediscovered correctly, and the COM port, such as COM3, may not be re-created. Additionally, you may receive an error message that resembles the following:

Device does not exist.

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Cause

This problem occurs because of a race condition in the Usbser.sys driver during surprise removal and rediscovery of the same device. This causes the corresponding COM port not to be re-created.

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Resolution

To resolve this issue, we have released a hotfix for Windows 7 and Windows Server 2008 R2, and we have released an update rollup for Windows 8.1 and Windows Server 2012 R2.

Get the update rollup for Windows 8.1 and Windows Server 2012 R2

To resolve this issue, install the December 2014 update rollup for Windows RT 8.1, Windows 8.1, and Windows Server 2012 R2.

Get the hotfix for Windows 7 and Windows Server 2008 R2

A supported hotfix is available from Microsoft Support. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, go to the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Service Pack 1 for Windows 7 or Windows Server 2008 R2 installed. Additionally, you must have security update 2884256 installed.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any previously released hotfix.

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File information
The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.

Windows 7 and Windows Server 2008 R2 file information and notes

Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.

    VersionProductSR_LevelService branch
    6.1.760
    1.
    22xxx
    Windows 7 and Windows Server 2008 R2SP1LDR
  • GDR service branches contain only those fixes that are widely released to address widespread, extremely important issues. LDR service branches contain hotfixes in addition to widely released fixes.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows 7 and Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 7
File nameFile versionFile sizeDateTimePlatform
Usbser.sys6.1.7601.2276228,16008-Aug-201400:55x86
For all supported x64-based versions of Windows 7 and Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Usbser.sys6.1.7601.2276233,28008-Aug-201401:10x64
For all supported IA-64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Usbser.sys6.1.7601.2276284,48008-Aug-201400:37IA-64

Additional file information for Windows 7 and Windows Server 2008 R2

Additional files for all supported x86-based versions of Windows 7
File nameX86_mdmcpq.inf_31bf3856ad364e35_6.1.7601.22762_none_756d7f962c5575f1.manifest
File versionNot applicable
File size1,731
Date (UTC)08-Aug-2014
Time (UTC)02:07
SHA-1 hashNot applicable
MD5 hashNot applicable
Additional files for all supported x64-based versions of Windows 7 and Windows Server 2008 R2
File nameAmd64_mdmcpq.inf_31bf3856ad364e35_6.1.7601.22762_none_d18c1b19e4b2e727.manifest
File versionNot applicable
File size1,733
Date (UTC)08-Aug-2014
Time (UTC)02:26
SHA-1 hashNot applicable
MD5 hashNot applicable
Additional files for all supported IA-64-based versions of Windows Server 2008 R2
File nameIa64_mdmcpq.inf_31bf3856ad364e35_6.1.7601.22762_none_756f238c2c537eed.manifest
File versionNot applicable
File size1,732
Date (UTC)08-Aug-2014
Time (UTC)01:58
SHA-1 hashNot applicable
MD5 hashNot applicable

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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References

Learn about the terminology that Microsoft uses to describe software updates.

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Keywords: kb, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbexpertiseinter, kbsurveynew, kbbug

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Article Info
Article ID : 2990372
Revision : 1
Created on : 1/7/2017
Published on : 12/9/2014
Exists online : False
Views : 246