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Stop error 0x000000D1 after you install the Hyper-V role on a computer that's running Windows Server 2012


View products that this article applies to.

Symptoms

After you install the Hyper-V role on a computer that's running Windows Server 2012, you may receive the following Stop error message:

0x000000D1 (parameter1 , parameter2 , parameter3 , parameter4 )
DRIVER_IRQL_NOT_LESS_OR_EQUAL

Notes
  • The parameters in this error message vary, depending on the configuration of the computer.
  • Not all "0x000000D1" Stop errors are caused by this problem.

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Cause

This problem occurs because of incorrect handling of the IP address structure inside the Vmswitch.sys file.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft Support. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, go to the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

There are no prerequisites for installing this hotfix.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any previously released hotfix.

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File information
The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.

Windows 8 and Windows Server 2012 file information and notes

Important Windows 8 and Windows Server 2012 hotfixes are included in the same packages. However, only "Windows 8" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 8" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.

    VersionProductMilestoneService branch
    6.2.920 0.16 xxxWindows 8 and Windows Server 2012RTMGDR
    6.2.920 0.21 xxxWindows 8 and Windows Server 2012RTMLDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows 8 and Windows Server 2012" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows 8 and Windows Server 2012
File nameFile versionFile sizeDateTimePlatform
Vmsif.dll6.2.9200.1638446,08026-Jul-201203:07x64
Vmsntfy.dll6.2.9200.1638489,08826-Jul-201203:07x64
Vmswitch.sys6.2.9200.21193566,78409-Aug-201405:59x64

Additional file information for Windows 8 and Windows Server 2012

Additional files for all supported x64-based versions of Windows 8 and Windows Server 2012
File nameAmd64_9f4cb925c3f9b9244f482ab0c302bbf5_31bf3856ad364e35_6.2.9200.21193_none_ade6634cb27903c2.manifest
File versionNot Applicable
File size708
Date (UTC)09-Aug-2014
Time (UTC)19:25
PlatformNot Applicable
File nameAmd64_microsoft-hyper-v-drivers-vmswitch_31bf3856ad364e35_6.2.9200.21193_none_c25291032307e2f8.manifest
File versionNot Applicable
File size162,594
Date (UTC)09-Aug-2014
Time (UTC)19:25
PlatformNot Applicable
File nameAmd64_wvms_pp.inf_31bf3856ad364e35_6.2.9200.21193_none_bc2ceadd944d5bec.manifest
File versionNot Applicable
File size3,379
Date (UTC)09-Aug-2014
Time (UTC)19:25
PlatformNot Applicable

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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References

Learn about the terminology that Microsoft uses to describe software updates.

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Keywords: kb, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbexpertiseinter, kbsurveynew, kbbug

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Article Info
Article ID : 2989586
Revision : 1
Created on : 1/7/2017
Published on : 9/9/2014
Exists online : False
Views : 207