Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Windows Store apps are not updated automatically in Windows 8.1


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have a Windows 8.1-based device that is connected to the Internet through a proxy.
  • You configure Windows Store to obtain updates automatically.

In this scenario, the Windows Store apps are not updated automatically.

↑ Back to the top


Cause

This problem occurs when you use a statically configured Proxy Auto Configuration (PAC) file.

↑ Back to the top


Resolution

How to obtain this hotfix

This�hotfix is available from the following Microsoft websites:
Microsoft Update
This�hotfix is available from�Microsoft Update.
Microsoft Download Center
The following files are available for download from the Microsoft Download Center:

Prerequisites

To apply this hotfix, you must first have update 2919355 installed in Windows 8.1 or Windows Server 2012 R2.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any previously released hotfix.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


References

Learn about the terminology that Microsoft uses to describe software updates.

↑ Back to the top


Article Info
Article ID : 2989542
Revision : 2
Created on : 10/14/2014
Published on : 10/14/2014
Exists online : False
Views : 292