Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Fail to register SPF in the Windows Azure Pack Service Management Portal with "Service URL or credentials are not valid"


View products that this article applies to.

Symptoms

When you try to register Microsoft System Center 2012 R2 Service Provider Foundation (SPF) in the Windows Azure Pack (WAP) Service Management Portal, registration fails with the following error:

There was an error registering System Center Service Provider Foundation.

When you click the Detailsbutton, you receive the following additional message:

The Service URL or credentials are not valid

A message that resembles the following will also be logged in the Microsoft-WindowsAzurePack-MgmtSvc-AdminSite
Operational event log:

Log Name: Microsoft-WindowsAzurePack-MgmtSvc-AdminSite/Operational
Source:        Microsoft-WindowsAzurePack-MgmtSvc-AdminSite
Event ID:      12
Task Category: (65522)
Level:         Error
Keywords:      None
User:          IIS APPPOOL\MgmtSvc-AdminSite
Description:
Error:JsonException: The Service URL or credentials are not valid.
<Exception>
  <Type>JsonException</Type>
  <Message>The Service URL or credentials are not valid.</Message>
  <StackTrace><![CDATA[
   at Microsoft.WindowsAzure.Server.SystemCenter.AdminExtension.Controllers.SystemCenterAdminController.<UpdateOrCreateSpfResourceProvider>d__298.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
   at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
   at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
   at lambda_method(Closure , Task )
   at System.Web.Mvc.Async.TaskAsyncActionDescriptor.EndExecute(IAsyncResult asyncResult)
   at System.Web.Mvc.Async.AsyncControllerActionInvoker.<>c__DisplayClass3f.<BeginInvokeAsynchronousActionMethod>b__3e(IAsyncResult asyncResult)
   at System.Web.Mvc.Async.AsyncControllerActionInvoker.<>c__DisplayClass37.<>c__DisplayClass39.<BeginInvokeActionMethodWithFilters>b__33()
   at System.Web.Mvc.Async.AsyncControllerActionInvoker.<>c__DisplayClass4f.<InvokeActionMethodFilterAsynchronously>b__49()
   at System.Web.Mvc.Async.AsyncControllerActionInvoker.<>c__DisplayClass4f.<InvokeActionMethodFilterAsynchronously>b__49()
   at System.Web.Mvc.Async.AsyncControllerActionInvoker.<>c__DisplayClass4f.<InvokeActionMethodFilterAsynchronously>b__49()
   at System.Web.Mvc.Async.AsyncControllerActionInvoker.<>c__DisplayClass37.<BeginInvokeActionMethodWithFilters>b__36(IAsyncResult asyncResult)
   at System.Web.Mvc.Async.AsyncControllerActionInvoker.<>c__DisplayClass25.<>c__DisplayClass2a.<BeginInvokeAction>b__20()
   at System.Web.Mvc.Async.AsyncControllerActionInvoker.<>c__DisplayClass25.<BeginInvokeAction>b__22(IAsyncResult asyncResult)]]></StackTrace>
  <HttpContext>
    <User IsAuthenticated="true" Name="CONTOSO\MarkStan" />
    <Request>
      <RawUrl>/SystemCenterAdmin/UpdateOrCreateSpfResourceProvider</RawUrl>
      <UserHostAddress>fe80::6582:32d1:1a42:fcf9%12</UserHostAddress>
      <Headers>
        <Header Key="Cache-Control" Value="no-cache" />
        <Header Key="Connection" Value="Keep-Alive" />
        <Header Key="Content-Length" Value="84" />
        <Header Key="Content-Type" Value="application/json" />
        <Header Key="Accept" Value="application/json, text/javascript, */*; q=0.01" />
        <Header Key="Accept-Encoding" Value="gzip, deflate" />
        <Header Key="Accept-Language" Value="en-US" />
        <Header Key="Host" Value="wap06admsrv.contoso.com:30091" />
        <Header Key="Referer" Value="https://wap06admsrv.contoso.com:30091/#Workspaces/SystemCenterAdminExtension/quickStart" />
        <Header Key="User-Agent" Value="Mozilla/5.0 (Windows NT 6.3; WOW64; Trident/7.0; rv:11.0) like Gecko" />
        <Header Key="x-ms-client-session-id" Value="c8048b68-b914-4666-b146-64271d627107" />
        <Header Key="x-ms-client-antiforgery-id" Value="s41IOZZe8tbJWx8X1FsKT/rBCuKKLKPWhlsgfsjlqUN8SWjT2Qbh0wbsSdmSrR3Nq3Jh0RiOo3vTKrANlpNPAZRTz1vdLSI4oxPjsPhbFA15VH8rG1Lgup8gNkT8fIRMUmAMDFRGJEBlKLgLH8jaWw==" />
        <Header Key="x-ms-client-request-id" Value="c8fcfacb-60e6-4e6d-ab3a-073dc64fdf74-2014-07-29 15:46:42Z" />
        <Header Key="X-Requested-With" Value="XMLHttpRequest" />
        <Cookies>
          <Cookie Name="sub" Secure="false" Expires="0001-01-01T00:00:00Z" Domain="" Path="/" Value="Redacted (4 characters)" />
          <Cookie Name="__RequestVerificationToken_Admin" Secure="false" Expires="0001-01-01T00:00:00Z" Domain="" Path="/" Value="Redacted (128 characters)" />
          <Cookie Name="AdminSiteFedAuth" Secure="false" Expires="0001-01-01T00:00:00Z" Domain="" Path="/" Value="Redacted (2000 characters)" />
          <Cookie Name="AdminSiteFedAuth1" Secure="false" Expires="0001-01-01T00:00:00Z" Domain="" Path="/" Value="Redacted (396 characters)" />
        </Cookies>
      </Headers>
    </Request>
  </HttpContext>
</Exception>, operationName:SystemCenterAdmin.UpdateOrCreateSpfResourceProvider, version:, accept language:en-US, subscription Id:, client request Id:c8fcfacb-60e6-4e6d-ab3a-073dc64fdf74-2014-07-29 15:46:42Z, principal Id:CONTOSO\MarkStan, page request Id:c8048b68-b914-4666-b146-64271d627107, server request id:


↑ Back to the top


Cause

This error may occur if the SPF web site has two entries registered for the same TCP port binding. This can occur if the value was changed before SPF Update Rollup 2 was applied.

↑ Back to the top


Resolution

To resolve this issue, follow these steps: 

  1. Log on to the SPF server as a user who has administrative rights, and then open Internet Information Services (IIS) Manager. 
  2. Move to <SERVERNAME>\Sites\SPF, and then highlight the SPF website on the left pane. 
  3. Click Bindings..., Select the duplicate entry, and then choose Remove.
  4. Click Yes, and then click Close to exit the dialog box.
  5. Click Start to start the website. 
  6. Return to the WAP Service Management Portal (Admin Portal), and reregister SPF.

↑ Back to the top


More Information

This is a known issue with System Center 2012 R2 Update Rollup 2 for SPF.

↑ Back to the top


Keywords: kb, kbsurveynew, kbtshoot, kbexpertiseadvanced

↑ Back to the top

Article Info
Article ID : 2988915
Revision : 2
Created on : 3/27/2020
Published on : 3/27/2020
Exists online : False
Views : 361