Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Fatal error during installation of Microsoft Dynamics CRM 2013 Report Authoring Extensions


View products that this article applies to.

Symptoms

After attempting to install Microsoft Dynamics CRM 2013 Report Authoring Extensions, an error is received after installing the Windows Live ID Sign-In Assistant pre-requisite:

Microsoft Dynamics CRM Report Authoring Extension Setup
Action Microsoft.Crm.Setup.Common.Analyzer+CollectAction failed.
Fatal error during installation

Consider the following scenario:

An installation of Microsoft Dynamics CRM 2011 Report Authoring Extensions is attempted, however during installation the setup wizard throws an error during the Environment Check and/or User Input Check steps. After this, an installation of Microsoft Dynamics CRM 2013 Report Authoring Extensions is attempted as the wrong version had been attempted in the first installation.

↑ Back to the top


Cause

Multiple version installations of Microsoft Dynamics CRM Report Authoring Extensions attempted on the same machine

↑ Back to the top


Resolution

To resolve this issue, a registry entry will need to be removed from the machine before proceeding with the Microsoft Dynamics CRM 2013 Report Authoring Extensions installation:


WARNING: Using Registry Editor incorrectly can cause serious problems that may require you to reinstall Windows. Microsoft cannot guarantee that problems resulting from the incorrect use of Registry  Editor can be solved. Use Registry Editor at your own risk.


1. Navigate to the Start Menu (or Windows key + R will perform steps 1 and 2)

2. In the search bar, type Run and hit enter

3. In the open lookup, type Regedit and hit enter

4. Expand the Windows Registry tree to the following registry directory:
HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\UserData\S-1-5-18\Components\0EF1E6B4EFCDA2649B26A424D56DAACD
a. HKEY_LOCAL_MACHINE
 b. Software
 c. Microsoft
 d. Windows
 e. CurrentVersion
 f. Installer
 g. UserData
 h. S-1-5-18
 i. Components
j. 0EF1E6B4EFCDA2649B26A424D56DAACD

5. Examine the registry key '0EF1E6B4EFCDA2649B26A424D56DAACD' for multiple string value registry entries
 a. A single string value should be present in this directory - the scenario outlined in the symptom will result in two string registry entries being created.

6. Right-Click on the registry key 0EF1E6B4EFCDA2649B26A424D56DAACD and select Export
 a. Save the registry backup to a location on the local computer

7. Right-Click on the registry key 0EF1E6B4EFCDA2649B26A424D56DAACD and select Delete
 Note: This key is created during setup and will be recreated as part of the setup process

8. Start the Microsoft Dynamics CRM 2013 Report Authoring Extensions installation wizard

↑ Back to the top


Keywords: kbmbspartner, kbmbsmigrate, kbsurveynew, kb

↑ Back to the top

Article Info
Article ID : 2988630
Revision : 1
Created on : 1/7/2017
Published on : 7/28/2014
Exists online : False
Views : 270