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Cannot print by using a Hewlett Packard XPS-based print driver after you install KB2769165


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Symptoms

You cannot print by using a Hewlett Packard (HP) XPS-based print driver on a Windows 8 or Windows 8.1 PC.

You installed Windows Update KB2769165 while the PC was running Windows 8.

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Cause

Windows Update KB2769165 contains new versions of the in-box XPS-based Print Class drivers. When Windows Update KB2769165 is installed, two of the driver files that are installed have the same name as files that are used by the HP XPS-based driver. These two files are hpbxpsrender.dll and hpmacronames.gpd. The two versions of the files are incompatible. Therefore, after the KB2769165 versions are installed, the HP XPS driver will no longer work. Reinstalling the HP driver will not resolve the issue. As the KB2769165 versions have a higher version number, they are not overwritten by the driver installation. 

If Windows Update KB2769165 was installed on Windows 8, and then the system was upgraded to Windows 8.1, the issue will persist in Windows 8.1.

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Resolution

Fix it for me

To fix the issue automatically, download the HPXPSDriver.diagcab package and run it on your computer.

Let me fix it myself

You must check the properties of the printer driver to verify that you are affected by this issue by following these steps:
  1. Open Windows Explorer.
  2. Open the appropriate folder, depending on your operating system:
    • 64-bit versions of Windows: c:\windows\system32\spool\drivers\x64\3
    • 32-bit versions of Windows: c:\windows\system32\spool\drivers\W32X86\3

      Note: If Windows is not installed on Drive C, replace C: with the appropriate system drive letter.
  3. Find a file called hpbxpsrender.dll. Right-click the file, and then select Properties.
  4. Click the Details tab. If the file version matches 0.3.8315.0, continue to the next step. If the file version that is listed is not 0.3.8315.0, stop here as you are not affected by the issue described in this article. As soon as you have verified the version number, restore the correct driver packages by following the remaining steps.
  5. Open an elevated command prompt. From the Start screen, type cmd, and then right-click or press and hold Command Prompt in the search results. Then tap or click Run as administrator.
  6. In the Administrator: Command Prompt window, type the following command and press Enter:
    Net stop spooler 
  7. As soon as the spooler has stopped running, go back to folder that you opened in step 2. (For example, on 64-bit Windows, open C:\windows\system32\spool\drivers\x64\3.)
  8. Delete the following two files: hpbxpsrender.dll and hpmacronames.gpd
  9. Then open folder C:\Windows\System32\DriverStore\FileRepository
  10. Look for a folder that begins with "hpvyt". If there are more than one, find the one with the highest number (" hpvyt14…", " hpvyt13…", and so on). Then open that folder.
  11. Find a file that is named hpmacronames.gpd. Copy this file and paste it in the folder that you opened in step 2. (For example, on 64-bit Windows, open c:\windows\system32\spool\drivers\x64\3.)
  12. Under the folder that you opened in step 11 (the folder that begins with "hpvyt"), open the V3 subfolder, and then open the amd64 subfolder within it.
  13. Find a file that is named hpbxpsrender.dll. Copy this file and then paste it in the folder that you opened in step 2.  (For example on 64-bit Windows, open c:\windows\system32\spool\drivers\x64\3.)
  14. Return to the Administrator: Command Prompt window, type the following command, and then press Enter:
    Net start spooler 
  15. Close all windows. You should now be able to print by using the new HP XPS driver.


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Keywords: kb

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Article Info
Article ID : 2987964
Revision : 1
Created on : 1/7/2017
Published on : 9/12/2014
Exists online : False
Views : 427