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"Object reference not set to an instance of an object" error occurs when configuring the Microsoft Dynamics CRM for Outlook client


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Symptoms

When configuring the Microsoft Dynamics CRM 2011 or CRM 2013 for Outlook client to a Microsoft Dynamics CRM Online instance, an "Object reference not set to an instance of an object" error occurs after entering your credentials, choosing your organization, and clicking OK:


There is a problem communicating with the Microsoft Dynamics CRM server. The server might be unavailable. Try again later. If the problem persists, contact your system administrator.

Object reference not set to an instance of an object.

at Microsoft.Crm.Passport.IdCrl.OnlineServicesFederationLogOnManager.GetBrowserClientAuthInfo(String redirectEndpoint, String partner, String policy, String& postData)

at Microsoft.Crm.Outlook.ClientAuth.PassportAuthProvider`1.SignIn()

at Microsoft.Crm.Outlook.ClientAuth.ClientAuthProvidersFactory`1.SignIn(Uri endPoint, Credential credentials, AuthUIMode uiMode, IClientOrganizationContext context, Form parentWindow, Boolean retryOnError)

at Microsoft.Crm.Outlook.ClientAuth.ClientAuthProvidersFactory`1.GetAuthProvider(Uri endPoint, Credential credentials, AuthUIMode uiMode, Uri webEndPoint, IClientOrganizationContext context, Form parentWindow)

at Microsoft.Crm.Application.Outlook.Config.ServerInfo.LoadUserId()

at Microsoft.Crm.Application.Outlook.Config.ServerInfo.Initialize(Uri discoveryUri, OrganizationDetail selectedOrg, String displayName, Boolean isPrimary)

at Microsoft.Crm.Application.Outlook.Config.ServerForm.LoadDataToServerInfo()

at Microsoft.Crm.Application.Outlook.Config.ServerForm.<InitializeBackgroundWorkers>b__2(Object sender, DoWorkEventArgs e)

at System.ComponentModel.BackgroundWorker.OnDoWork(DoWorkEventArgs e)

at System.ComponentModel.BackgroundWorker.WorkerThreadStart(Object argument)

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Cause

This issue occurs if you are using a version of the Microsoft Online Services Sign-in Assistant that is incompatible with Microsoft Dynamics CRM 2011 or Microsoft Dynamics CRM 2013. When configuring the Microsoft Dynamics CRM for Outlook client and connecting to a Microsoft Dynamics CRM Online instance, the only supported versions of the Microsoft Online Services Sign-in Assistant are 7.250.4259.0, 7.250.4287.0, and 7.250.4303.0.

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Resolution

To resolve this issue, please perform the following steps:

1. Click Start, type appwiz.cpl, and then press Enter to open the Programs and Features item in Control Panel.

2. Uninstall the Microsoft Online Services Sign-in Assistant if its version does not match 7.250.4259.0, 7.250.4287.0, or 7.250.4303.0.

3. Download and reinstall version 7.250.4303.0 of the Microsoft Online Services Sign-in Assistant.

4. Restart your workstation and configure the Microsoft Dynamics CRM for Outlook client to verify the issue is resolved.

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Keywords: kbmbspartner, kbmbsmigrate, kbsurveynew, kb

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Article Info
Article ID : 2986728
Revision : 1
Created on : 1/7/2017
Published on : 7/22/2014
Exists online : False
Views : 288