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Assistant stops processing new requests when Events in Queue value exceeds 500 in Exchange Server 2010


View products that this article applies to.

Symptoms

When you use Microsoft Exchange Server 2010, Exchange assistants, such as Calendar Assistant, stop processing events. 

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Cause

This issue occurs when the number of events to process in the Events in Queue field is greater than 500. In this situation, a race condition occurs where the event dispatcher does not decrement the counter value when a mailbox is occupied in another thread.

Note The Events in Queue instance of the MSExchange Assistants - Per Assistant object in Performance Monitor counts the number of events to process.

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Resolution

To resolve this issue, install the following update:
2961522 Update Rollup 7 for Exchange Server 2010 Service Pack 3

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Workaround

To work around this issue, restart the Microsoft Exchange Mailbox Assistant service.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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Keywords: kbqfe, kbfix, kbsurveynew, kbexpertiseadvanced, kb

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Article Info
Article ID : 2976322
Revision : 1
Created on : 1/7/2017
Published on : 8/26/2014
Exists online : False
Views : 166