Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Account balance is missing in Management Reporter 2012 for Dynamics GP when 'Exclude inactive accounts' is checked


View products that this article applies to.

Symptom

Consider this scenario:

When you generate a report in Management Reporter 2012 using the data mart with Microsoft Dynamics GP, the balance for some accounts are missing. This happens if you select the option Exclude inactive accounts, on the Additional Options tab of the report settings. If you clear this option, the account balance will display on the report.

↑ Back to the top


Cause

When an account is marked as inactive in Microsoft Dynamics GP, all of the accounts with the same main account number will be marked as inactive in Management Reporter 2012.

For example, in Dynamics GP there is an account with a full account number of 00-1100-320. This account is marked inactive. The main account segment is 1100. There is another account with a full account number of 00-1100-420. This account is considered active in Microsoft Dynamics GP. If the Exclude inactive accounts checkbox is selected when you generate a report that includes the main account number of 1100 in the row definition, both of the 1100 accounts will return a result of zero.
  

↑ Back to the top


Resolution

 
There are two option for this.

Option 1: Leave the Exclude inactive accounts checkmark unchecked in the Additional Options of the Report Settings.

  1. In the report designer, select Report definitions in the navigation section, and double click to open the report definition.
  2. On the Settings tab, click Other, and then click Additional Options. Clear the check box next to Exclude inactive accounts.
  3. Click OK, save the report definition, and then generate the report.

Option 2: Leave the account active in Dynamics GP.

  1. In Microsoft Dynamics GP, click Cards, click Financial and then click Account .
  2. Search for the account number and then clear the Inactive check box. Leave the option Allow Account Entry cleared.
This option will adjust the account so that it is no longer marked as inactive, but transactions cannot be posted to the account within Microsoft Dynamics GP.





↑ Back to the top


More Information

This functionality is by design, however this could be changed in a future release of Management Reporter 2012.

↑ Back to the top


Keywords: kb

↑ Back to the top

Article Info
Article ID : 2975343
Revision : 1
Created on : 1/7/2017
Published on : 10/1/2014
Exists online : False
Views : 267