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Multiple authentication dialog boxes are displayed when you use access control


View products that this article applies to.

This article was previously published under Q297324
Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 (http://support.microsoft.com/kb/256986/ ) Description of the Microsoft Windows registry

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Symptoms

When a destination set is configured, the client receives an HTTP 407 error for each domain that is restricted. As a result, the client browser is prompted for authentication. If the destination that is set is restricted to a domain that contains multiple links to other domains, an authentication dialog box appears for each unauthorized link.

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Cause

When a domain authentication request is denied, Internet Security and Acceleration (ISA) Server returns a 407 error (or a 401 error in reverse proxy). RFC 2068 defines this message as follows:
407 Proxy Authentication Required

This code is similar to 401 (Unauthorized), but indicates that the client MUST first authenticate itself with the proxy. The proxy MUST return a Proxy-Authenticate header field (section 14.33) containing a challenge applicable to the proxy for the requested resource. The client MAY repeat the request with a suitable Proxy-Authorization header field (section 14.34). HTTP access authentication is explained in section 11.

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Resolution

Service pack

To resolve this problem, obtain the latest service pack for Internet Security and Acceleration Server 2000. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
313139� How to obtain the latest Internet Security and Acceleration Server 2000 service pack

Hotfix

If you install the following hotfix, ISA Server returns a 502 "Bad Gateway" error (or a 403 "Forbidden" error in reverse proxy). When the client browser sees the 502 or 403 error, it displays a red "X" for that content. This behavior eliminates the unwanted authentication dialog boxes. A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date       Time   Version       Size     File name   Platform
   -------------------------------------------------------------
   06/12/2001 06:14  3.0.1200.65   373,520  W3proxy.exe x86 
				

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Workaround

To work around this problem, expand the destination list to include all of the domains that are linked to the necessary domain. To obtain this expanded list, use a product such as Microsoft Site Server Content Analyzer that can crawl a domain. You can also look at the HTML source or through a network trace to find the linked domains. Another way to get this functionality is to use third-party filtering software to restrict access. For a complete list of these products, see the following Microsoft Web site:

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

This problem was first corrected in Internet Security and Acceleration Server 2000 Service Pack 1.

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More information

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

After you install this hotfix, you must manually create the ReturnDeniedIfAuthenticated registry value as follows:
  1. Click Start, click Run, type regedt32 in the Open box, and then press ENTER to start Registry Editor.
  2. Locate and then click the following key in the registry:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\W3proxy\Parameters
  3. On the Edit menu, click Add Value, and then add the following registry value:
    Value Name: ReturnDeniedIfAuthenticated
    Data Type: REG_DWORD
    Radix: Hex
    Value Data: 1
  4. Quit Registry Editor.

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Keywords: KB297324, kbprb, kbhotfixserver, kbqfe, kbproductlink, kbautohotfix

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Article Info
Article ID : 297324
Revision : 13
Created on : 10/26/2007
Published on : 10/26/2007
Exists online : False
Views : 349