Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Host Microcode update for Intel processors to improve the reliability of Windows Server


View products that this article applies to.

Introduction

This article describes a microcode update for Intel processors in Windows Server 2012 R2, Windows Server 2012, and Windows Server 2008 R2 Service Pack 1 (SP1). This update improves the reliability of x64-based versions of Windows Server that use certain Intel processors.

This update must be installed only on a problematic Windows Server host that has the Hyper-V role installed and that's running on an Intel Ivy Bridge, Ivy Town, or Haswell processor. 

↑ Back to the top


Symptoms

A virtual guest system may crash in Windows Hyper-V or VMware when the host system uses one of the Intel processors that's mentioned in the "Introduction" section.

↑ Back to the top


Cause

This issue occurs because Ivy Bridge, Ivy Town, and Haswell processors require a firmware upgrade that contains a CPU microcode update. Virtual machines that are running on Virtualization hosts, either Hyper-V or VMware may experience operating system crashes to include stop errors.

↑ Back to the top


Resolution

For Windows Hyper-V hosts, this article you are reading contains the released hotfix to be installed on the Hyper-V Host to fix this issue for Windows Server 2012 R2, Windows Server 2012, or Windows Server 2008 R2 Hyper-V Hosts.

For VMware hosts, contact your original equipment manufacturer to obtain the updated firmware that contains the fixed Intel microcode. VMware hosts must have this BIOS update installed to fix the issue. As per VMware, please open a support ticket with VMware referencing PR #1178834 to log the issue.

Additionally, this issue can also be fixed by upgrading the Intel processors on the Hyper-V or VMware hosts.

Get the hotfix for Windows Server 2012 R2, Windows Server 2012, or Windows Server 2008 R2

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2012 R2, Windows Server 2012 or Windows Server 2008 R2 SP1.

Registry information

To apply this hotfix, you do not have to make any changes to the registry.

Restart requirement

You may have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.
File information
The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.

Windows RT 8.1, Windows 8.1, and Windows Server 2012 R2 file information notes
Important Windows 8.1 hotfixes and Windows Server 2012 R2 hotfixes are included in the same packages. However, only "Windows 8.1" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 8.1" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
    Version Product Milestone Service branch
    6.3.960 0.17 xxxWindows RT 8.1, Windows 8.1, and Windows Server 2012 R2 RTM GDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information" section. MUM, MANIFEST, and the associated security catalog (.cat) files, are very important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2012 R2
File nameFile versionFile sizeDateTimePlatform
Mcupdate_genuineintel.dll6.3.9600.17227478,52804-Jul-201421:29x64
Windows RT, Windows 8, and Windows Server 2012 file information notes
Important Windows 8 and Windows Server 2012 hotfixes are included in the same packages. However, only "Windows 8" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 8" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
    VersionProductMilestoneService branch
    6.2.920 0.16 xxxWindows RT, Windows 8, and Windows Server 2012RTMGDR
    6.2.920 0.21xxxWindows RT, Windows 8, and Windows Server 2012RTMLDR
  • GDR service branches contain only those fixes that are widely released to address widespread, critical issues. LDR service branches contain hotfixes in addition to widely released fixes.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information" section. MUM, MANIFEST, and the associated security catalog (.cat) files, are very important to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2012
File nameFile versionFile sizeDateTimePlatform
Mcupdate_genuineintel.dll6.2.9200.17048485,69607-Jul-201406:43x64
Mcupdate_genuineintel.dll6.2.9200.21166485,69607-Jul-201406:50x64
Windows 7 and Windows Server 2008 R2 file information and notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, milestone (RTM,SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:

    VersionProductMilestoneService branch
    6.1.760 1.18xxxWindows 7 and Windows Server 2008 R2SP1GDR
    6.1.760 1.22xxxWindows 7 and Windows Server 2008 R2SP1LDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information" section. MUM, MANIFEST, and the associated security catalog (.cat) files, are very important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Mcupdate_genuineintel.dll6.1.7601.18548443,32002-Aug-201402:12x64
Mcupdate_genuineintel.dll6.1.7601.22758443,32002-Aug-201402:04x64

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More Information

Solaris 10 64-bit kernel panic in VMware
VMware users may also experience 64-bit Solaris 10 kernel panic.
For temporary relief from the virtual guest crashes or if no OEM firmware upgrade is available, VMware recommends changing the virtual machines' MMU mode in the affected host to Software or upgrade your host to ESXi 5.5 Update 2.

Note There is no fix for ESXi 5.1 hosts.

See How to change the virtual machine monitor mode (1036775) from the VMware site.
For more information about this issue, see Windows 2008 R2 and Solaris 10 64-bit virtual machines blue screen or kernel panic when running on ESXi 5.x with an Intel E5 v2 series processor in the VMware site.



For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Server 2012 R2

Additional files for all supported x64-based versions of Windows Server 2012 R2
File nameAmd64_efdc53b826392e7eecad18c0d823eb3a_31bf3856ad364e35_6.3.9600.17227_none_dff23963c49b15ac.manifest
File versionNot Applicable
File size721
Date (UTC)05-Jul-2014
Time (UTC)03:41
PlatformNot Applicable
File nameAmd64_microsoft-windows-m..update-genuineintel_31bf3856ad364e35_6.3.9600.17227_none_adc2342486111591.manifest
File versionNot Applicable
File size2,571
Date (UTC)04-Jul-2014
Time (UTC)21:44
PlatformNot Applicable

Additional file information for Windows Server 2012

Additional files for all supported x64-based versions of Windows Server 2012
File nameAmd64_2cbe13f671c60a8e3bb9b6579db2240f_31bf3856ad364e35_6.2.9200.21166_none_ce22391bf64a4fa0.manifest
File versionNot Applicable
File size721
Date (UTC)07-Jul-2014
Time (UTC)13:19
PlatformNot Applicable
File nameAmd64_a7e7c6dfabf05070ee1faa1c1b85f3bd_31bf3856ad364e35_6.2.9200.17048_none_ddf39ab60b2e1852.manifest
File versionNot Applicable
File size721
Date (UTC)07-Jul-2014
Time (UTC)13:19
PlatformNot Applicable
File nameAmd64_microsoft-windows-m..update-genuineintel_31bf3856ad364e35_6.2.9200.17048_none_15b8d8243bed9bff.manifest
File versionNot Applicable
File size2,571
Date (UTC)07-Jul-2014
Time (UTC)06:53
PlatformNot Applicable
File nameAmd64_microsoft-windows-m..update-genuineintel_31bf3856ad364e35_6.2.9200.21166_none_162ad483551d40fd.manifest
File versionNot Applicable
File size2,571
Date (UTC)07-Jul-2014
Time (UTC)07:00
PlatformNot Applicable
File nameUpdate-bf.mum
File versionNot Applicable
File size2,433
Date (UTC)07-Jul-2014
Time (UTC)13:19
PlatformNot Applicable

Additional file information for Windows Server 2008 R2

Additional files for all supported x64-based versions of Windows Server 2008 R2
File nameAmd64_3e935e681df43de8bea7c4bde9276d2f_31bf3856ad364e35_6.1.7601.22758_none_345a7d43b6731ba2.manifest
File versionNot Applicable
File size721
Date (UTC)02-Aug-2014
Time (UTC)04:58
PlatformNot Applicable
File nameAmd64_68f9ee30bd2fd8e01b6cf438d575d558_31bf3856ad364e35_6.1.7601.18548_none_1c19519a83a7f7bf.manifest
File versionNot Applicable
File size721
Date (UTC)02-Aug-2014
Time (UTC)04:58
PlatformNot Applicable
File nameAmd64_microsoft-windows-m..update-genuineintel_31bf3856ad364e35_6.1.7601.18548_none_1ac98c6cc901ab55.manifest
File versionNot Applicable
File size2,532
Date (UTC)02-Aug-2014
Time (UTC)02:35
PlatformNot Applicable
File nameAmd64_microsoft-windows-m..update-genuineintel_31bf3856ad364e35_6.1.7601.22758_none_1b485b31e2276437.manifest
File versionNot Applicable
File size2,532
Date (UTC)02-Aug-2014
Time (UTC)02:25
PlatformNot Applicable
File nameUpdate-bf.mum
File versionNot Applicable
File size2,304
Date (UTC)02-Aug-2014
Time (UTC)04:58
PlatformNot Applicable

Third-party information disclaimer
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

↑ Back to the top


Keywords: kb, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbexpertiseadvanced

↑ Back to the top

Article Info
Article ID : 2970215
Revision : 1
Created on : 1/7/2017
Published on : 3/23/2016
Exists online : False
Views : 242