Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Fix restart problems after you install update rollup 2919355 in Windows 8.1 or Windows Server 2012 R2


View products that this article applies to.

Symptoms

After you install Update Rollup 2919355 (April 2014) for Windows RT 8.1, Windows 8.1, and Windows Server 2012 R2, or after you install any of these systems from media that includes this update rollup, you cannot restart the computer because the computer experiences a restart loop.

Update Rollup 2919355 may have been installed automatically through Windows Update (WU) or through Windows Server Update Services (WSUS) in your environment.

Computers that start from certain Serial Attached SCSI (SAS) storage controllers are affected by this problem. This includes, but is not limited to, the following controller drivers:
  • Dell H200 PERC controller
  • IBM x240 with on-board LSI SAS2004 ROC controller
  • LSI 2308 on-board controllers
  • LSI 9211-4i controllers
  • LSI 9211-8i controllers
  • LSI SAS 9211
  • Supermicro X10SL7-F motherboard
If the "Automatically restart" option to set the computer behavior after a failure is disabled, you receive the following Stop error message during startup:
Stop 0x7B INACCESSIBLE_BOOT_DEVICE

If the controller is connected to the data disk or just been connected, the following event ID messages may be logged in the Event Viewer:

↑ Back to the top


Cause

This problem occurs if the storage controller receives a memory allocation that starts on a 4 gigabyte (GB) boundary. In this situation, the storage driver does not load. Therefore, the system does not detect the boot disk and returns the Stop error message that is mentioned in the "Symptoms" section.

Additionally, if the controller is connected to the data disk or just been connected, the event messages that are mentioned in the "Symptoms" section may be logged.

Note This problem may not always occur in this situation. The problem is affected by the computer’s startup process, the driver load sequence, and the memory allocation of the storage controller driver at startup.

↑ Back to the top


Resolution

Update information

How to obtain this update

Windows Update
This update is available from Windows Update.
Microsoft Download Center
The following files are available for download from the Microsoft Download Center:
Operating systemUpdate
All supported x86-based versions of Windows 8.1Download Download the package now.
All supported x64-based versions of Windows 8.1Download Download the package now.
All supported x64-based versions of Windows Server 2012 R2Download Download the package now.
Note The update for Windows RT 8.1 can be obtained only from Windows Update.

For more information about how to download Microsoft support files, click the following article number to view the article in the Microsoft Knowledge Base:
119591 How to obtain Microsoft support files from online services
Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help prevent any unauthorized changes to the file.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix Download Available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix Download Available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.


Prerequisites

There is no prerequisite to apply this hotfix.

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You may have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.
File information
The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.

Windows 8.1 and Windows Server 2012 R2 file information and notes

Important Windows 8.1 hotfixes and Windows Server 2012 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 8.1/Windows Server 2012 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:

    VersionProductMilestoneService branch
    6.3.960 0.17 xxxWindows RT 8.1, Windows 8.1, and Windows Server 2012 R2RTMGDR
  • GDR service branches contain only those fixes that are widely released to address widespread, critical issues. LDR service branches contain hotfixes in addition to widely released fixes.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information" section. MUM, MANIFEST, and the associated security catalog (.cat) files, are very important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 8.1
File nameFile versionFile sizeDateTimePlatform
Storport.sys6.3.9600.17122311,64014-May-201404:01x86
For all supported x64-based versions of Windows 8.1 and of Windows Server 2012 R2
File nameFile versionFile sizeDateTimePlatform
Storport.sys6.3.9600.17122373,08014-May-201405:12x64
For all supported ARM-based versions of Windows 8.1
File nameFile versionFile sizeDateTimePlatform
Storport.sys6.3.9600.17122290,15214-May-201403:44Not applicable

Additional file information

Additional file information for Windows 8.1 and for Windows Server 2012 R2
Additional files for all supported x86-based versions of Windows 8.1
File propertyValue
File nameX86_459b6140b0164456488f84138003a7f0_31bf3856ad364e35_6.3.9600.17123_none_d0a628efa89c2163.manifest
File versionNot applicable
File size696
Date (UTC)14-May-2014
Time (UTC)23:16
PlatformNot applicable
File nameX86_microsoft-windows-storport_31bf3856ad364e35_6.3.9600.17123_none_bc5bd7da4b98d967.manifest
File versionNot applicable
File size78,096
Date (UTC)14-May-2014
Time (UTC)04:28
PlatformNot applicable
Additional files for all supported x64-based versions of Windows 8.1 and of Windows Server 2012 R2
File propertyValue
File nameAmd64_0e9866a53ebeaa0139d75e4687788fb8_31bf3856ad364e35_6.3.9600.17123_none_8318c5873deb91d6.manifest
File versionNot applicable
File size700
Date (UTC)14-May-2014
Time (UTC)23:16
PlatformNot applicable
File nameAmd64_microsoft-windows-storport_31bf3856ad364e35_6.3.9600.17123_none_187a735e03f64a9d.manifest
File versionNot applicable
File size78,098
Date (UTC)14-May-2014
Time (UTC)06:25
PlatformNot applicable
Additional files for all supported ARM-based versions of Windows 8.1
File propertyValue
File nameArm_801701a658d441200366df1ef8d01897_31bf3856ad364e35_6.3.9600.17123_none_1d6d7c8451e2547f.manifest
File versionNot applicable
File size696
Date (UTC)14-May-2014
Time (UTC)23:16
PlatformNot applicable
File nameArm_microsoft-windows-storport_31bf3856ad364e35_6.3.9600.17123_none_bc5e4a324b95f82d.manifest
File versionNot applicable
File size78,096
Date (UTC)14-May-2014
Time (UTC)05:03
PlatformNot applicable


↑ Back to the top


Installation information

The hotfix download provides Update 2966870 to resolve the problems that are mentioned in the "Symptoms" section. Before you run the installation media for Windows 8.1 Update or Windows Server 2012 R2 Update, you must inject Update 2966870 into the installation media. To do this, use one of the following methods.

Note The system descriptions in these steps assume that the installation media and computers that are used in this process are all 64-bit AMD64 architecture computers. For x86 or ARM architectures, follow these same steps but replace all references to "amd64" by using "x86 or "WOA," as appropriate.

Method 1: Preinstall this update into custom USB installation media

Use this method if the following conditions are true:
  • You plan to install a Windows operating system from a USB flash drive.
  • You have a Windows 8.1 or Windows Server 2012 R2 operating system available on a different computer.
  • You can use the other computer to manipulate files on the USB flash drive.
  • You have Windows 8.1 Update or Windows Server 2012 R2 Update source files available.
To inject this update into the USB installation media on a USB flash drive, follow these steps:
  1. On a cleanly FAT32-formatted USB flash drive, copy the whole contents of the Windows installation media to the root directory.
  2. Create a folder that is named C:\Bin.
  3. Create a folder that is named C:\Bin\2966870.
  4. Download the hotfix to the C:\Bin\2966870 folder.
  5. If the hotfix is an executable file (.exe), you have to run the file to extract the required files. Make sure that the files extract to C:\Bin\2966870.
  6. Among the extracted files, locate Windows8.1-KB2966870-x64.msu, and then rename it Windows8.1-KB2966870-x64.msu.cab.
  7. Double-click Windows8.1-KB2966870-x64.msu.cab, and then extract the Windows8.1-K2966870-x64.cab file to the C:\Bin\2966870 folder.

    Note This is the file that you will inject.
  8. Create a folder that is named C:\Bin\Mount.
  9. Create a folder that is named C:\Bin\MountRE.
  10. Create a folder that is named C:\Bin\Scratch.
  11. In the Windows 8.1 Update or Windows Server 2012 R2 Update installation media, locate the following files, and then copy the files to C:\Bin:

    \Sources\Boot.wim
    \Sources\Install.wim
  12. On the Windows 8.1-based or Windows Server 2012 R2-based computer, open an administrative command prompt. To do this, right-click Start, and then click Command prompt (Admin)
  13. At the command prompt, type CD C:\Bin, and then press Enter.
  14. Mount the first index of Boot.wim. To do this, run the following Deployment Image Servicing and Management (DISM) command at the command prompt:

    dism /mount-wim /wimfile=boot.wim /index:1 /mountdir=Mount 
    Note This command can take some time to finish.
  15. Inject the hotfix into the mounted WIM image. To do this, run the following DISM command:

    dism /image:.\Mount /add-package /packagepath:C:\Bin\2966870\Windows8.1-KB2966870-x64.cab /scratchdir=scratch 

    Note This command can take some time to finish.
  16. Verify that the package is added. To do this, run the following DISM command, and then examine the output for the hotfix number that you just injected:

    dism /image:.\mount /get-packages 
  17. Unmount and commit the changes to the currently mounted WIM image. To do this, run the following DISM command:

    dism /unmount-image /mountdir:.\Mount /commit 
    Note This command can take some time to finish.
  18. Repeat steps 14 through 17 for index 2 of the Boot.wim image, except change the index number in step 14 from 1 to 2.
  19. At the command prompt, run the following DISM command:

    dism /get-imageinfo /imagefile:C:\Bin\install.wim 
    Notes
    • A list of images that are included in the WIM and their associated index numbers is displayed.
    • You have to mount and inject the hotfix into the indexes that you plan to use. If you use more than one index, you have to inject the hotfix into multiple indexes.
    The following output shows an example of what the list might display.

    Deployment Image Servicing and Management tool
    Version: 6.3.9600.17031

    Details for image : C:\Bin\install.wim

    Index : 1
    Name : Windows Server 2012 R2 SERVERSTANDARDCORE
    Description : Windows Server 2012 R2 SERVERSTANDARDCORE
    Size : 6,897,618,255 bytes

    Index : 2
    Name : Windows Server 2012 R2 SERVERSTANDARD
    Description : Windows Server 2012 R2 SERVERSTANDARD
    Size : 12,069,723,893 bytes

    Index : 3
    Name : Windows Server 2012 R2 SERVERDATACENTERCORE
    Description : Windows Server 2012 R2 SERVERDATACENTERCORE
    Size : 6,876,269,628 bytes

    Index : 4
    Name : Windows Server 2012 R2 SERVERDATACENTER
    Description : Windows Server 2012 R2 SERVERDATACENTER
    Size : 12,066,707,039 bytes

    The operation completed successfully.
  20. Mount the index that you want to inject the update into. To do this, run the following DISM command:

    dism /mount-image /imagefile:C:\Bin\install.wim /index:# /mountdir:.\Mount 
    Notes
    • In this command, replace the number sign (#) by using the index number from the list in step 19 that corresponds to the index that you are mounting.
    • This command can take some time to finish.
  21. Set the Winre.wim attributes to be mountable. To do this, run the following command:

    Attrib -s -h mount\windows\system32\recovery\winre.wim 
  22. Mount the Windows RE image inside the Install.wim file. To do this, run the following DISM command:

    dism /mount-image /imagefile:.\mount\Windows\System32\Recovery\winre.wim /index:1 /mountdir:.\MountRE 
  23. Inject the update into the mounted WIM image. To do this, run the following DISM command:

    dism /image:.\Mount /add-package /packagepath:C:\Bin\2966870\Windows8.1-KB2966870-x64.cab /scratchdir:.\scratch 
    Note This command can take some time to finish.
  24. To verify that the package is added, run the following DISM command, and then examine the output for the hotfix number that you just injected:

    dism /image:.\mount /get-packages 
  25. Inject the update into the mounted Winre.wim image. To do this, run the following DISM command:

    dism /image:.\MountRE /add-package /packagepath:C:\Bin\2966870\Windows8.1-KB2966870-x64.cab /scratchdir:.\scratch 
    Note This command can take some time to finish.
  26. To verify that the package is added, run the following DISM command, and then examine the output for the hotfix number that you just injected:

    dism /image:.\MountRE /get-packages 
  27. Unmount and commit the changes to the currently mounted Winre.wim image. To do this, run the following DISM command:

    dism /unmount-image /mountdir:.\MountRE /commit 
    Note This command can take some time to finish.
  28. Unmount and commit the changes to the currently mounted WIM image. To do this, run the following DISM command:

    dism /unmount-image /mountdir:.\Mount /commit 
    Note This command can take some time to finish.
  29. Repeat steps 20 through 28 for each index identified in step 19.
  30. Copy the updated Boot.wim and Install.wim files from the C:\Bin folder to the \Sources folder on the USB flash drive that is currently being used for source media. Replace the existing versions of these files in the \Sources folder on the USB flash drive.

Method 2: Preinstall this update into custom ISO installation media

Use this method if the following conditions are true:
  • You plan to install a Windows operating system from a custom ISO image or DVD.
  • You have a Windows 8.1 or Windows Server 2012 R2 operating system available on a different computer.
  • You can use that computer to manipulate files.
  • You have Windows 8.1 Update or Windows Server 2012 R2 Update source files available
To inject this update into the installation media into an ISO image, follow these steps:
  1. Download and install the Windows Assessment and Deployment Kit (Windows ADK) for Windows 8.1 Update from the Microsoft Download Center.

    Note This kit provides the tools to create an ISO image that you can use to add installation files to a DVD.
  2. Follow steps 1-30 from Method 1, except do the following:
    • In step 1, instead of copying the files to a USB flash drive in step 1, copy the files to the C:\Bin\Media folder.
    • In step 30, copy the updated Boot.wim and Install.wim files to C:\Bin\Media\Sources, and replace the existing versions of these files in this folder.


    Note By default, this tool looks for the \Media folder.
  3. In the All Apps view, right-click Deployment and Imaging Tools Environment, and then click Run as Administrator.
  4. In the Command Prompt window that opens, navigate to the following location:

    C:\Program Files (x86)\Windows Kits\8.1\Assessment and Deployment Kit\Deployment Tools\amd64\Oscdimg
  5. At the command prompt, run the following command to build a bootable ISO image.

    Note This command builds a bootable Windows ISO image that is named Custom-Windows in the C:\Bin folder.

    oscdimg -m -o -u2 -udfver102 -bootdata:2#p0,e,betfsboot.com#pEF,e,befisys.bin C:\Bin\media C:\Bin\Custom-Windows.iso 

↑ Back to the top


Workaround

To recover from the "no boot" state when this problem occurs, try one or both of the following workaround methods.

Method 1

Try to restart the computer several times. You may occasionally be able to boot to the desktop by trying the process multiple times.

Method 2

  1. Start the computer from media for Windows RT 8.1, Windows 8.1, or Windows Server 2012 R2, select the Repair your computer option, click Troubleshoot, and then click Command Prompt.

    Note For this workaround, the media that you use should not include Update Rollup 2919355.
  2. At a command prompt, run the following command:

    Bcdedit /store <path of Boot Configuration Data (BCD)> /set {default} truncatememory 4294967296 
    Note The path of the BCD file is <drive letter>:\BOOT\BCD, in which the driver letter is the system partition. This command adds an entry to the BCD file under Windows Boot Loader that is named truncatememory. The new entry will have a value format of 0x100000000. For example, run the following command:

    Bcdedit /store C:\BOOT\BCD /set {default} truncatememory 4294967296
  3. Restart the computer. The computer should now boot to the desktop.

    Note If you were installing Update Rollup 2919355 when this problem occurred, the computer will continue to complete the installation of the update. After you successfully start Windows, uninstall Update Rollup 2919355.
  4. To remove the truncatememory boot option, run the following command at a command prompt:

    Bcdedit /deletevalue {default} truncatememory 
  5. Start the computer normally.


↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More Information

For the syntax to create an ISO image that can start on AMD64 (UEFI)-based computers and also on legacy MBR computers, see the following Microsoft Knowledge Base article:

947024 How to create an ISO image for UEFI platforms for a Windows PE CD-ROM for Windows Server 2008
For more information about Oscdimg Command-Line Options, see the following Microsoft TechNet topic:

Third-party information disclaimer
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

↑ Back to the top


Keywords: kbautohotfix, kbqfe, kbhotfixserver, kbfix, atdownload, kb

↑ Back to the top

Article Info
Article ID : 2966870
Revision : 2
Created on : 4/9/2020
Published on : 4/9/2020
Exists online : False
Views : 562