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You cannot manage newly added disks by using Storage Spaces on Windows Server 2012 or Windows Server 2012 R2


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Symptoms

Assume that you are using Storage Spaces in Windows Server 2012 or Windows Server 2012 R2. You hot-add a disk or you remove a disk from an enclosure that is managed by Storage Spaces. In this situation, you may encounter the following issues:
  • You cannot retrieve the slot or enclosure number of the disk.
  • You cannot control the failure or identity LED of the disk.

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Cause

This issue occurs because Storage Spaces is not aware of changes (such as hot-added disks) that are made to the physical storage device after it is started.

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Workaround

To work around this issue, run the following Windows PowerShell cmdlet after any physical changes are made to the storage device in order to update the cache:
Update-StorageProviderCache -DiscoveryLevel Full 
If you are using Server Manager, restart Server Manager after you update the cache by using this cmdlet.

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References

For more information about the Update-StorageProviderCache cmdlet, go to the following webpage at Microsoft TechNet:For more information about Storage Spaces, go to the following webpage at Microsoft TechNet:

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Keywords: kbsurveynew, kbtshoot, kbexpertiseinter, kb

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Article Info
Article ID : 2966566
Revision : 1
Created on : 1/7/2017
Published on : 5/15/2014
Exists online : False
Views : 383