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FIX: A zero value is always returned when an average counter of the "Forefront TMG Web Proxy" object is queried from the .NET Framework


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You develop an application by using the Microsoft .NET Framework.
  • The application queries one of the following Forefront TMG Web Proxy average counters:
    • Average Milliseconds/request
    • Average request processing rate (bytes/sec)
    • Current Array Fetches Average Milliseconds/request
    • Current Cache Fetches Average Milliseconds/request
    • Current Direct Fetches Average Milliseconds/request
    • Malware Inspection - Average Time in Queue (High Priority)
    • Malware Inspection - Average Time in Queue (Low Priority)
    • Malware Inspection - Average Time in Queue (Medium Priority)
In this scenario, the application always receives a zero (0) value when it queries the TMG counter.

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Cause

This problem occurs because of an issue in the TMG Performance Counter library (mspmon.dll).

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Resolution

To resolve this problem, install Rollup 5 for Forefront Threat Management Gateway (TMG) 2010 Service Pack 2.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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References

Learn about the terminology that Microsoft uses to describe software updates.

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Keywords: kbnotautohotfix, kbqfe, kbfix, kbexpertiseinter, kbbug, kbsurveynew, kb

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Article Info
Article ID : 2966284
Revision : 1
Created on : 1/7/2017
Published on : 6/17/2015
Exists online : False
Views : 231