Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

VHDX virtual hard disk takes a long time to be created on an SMB share on a Windows 8.1 or Windows Server 2012 R2 Hyper-V host


View products that this article applies to.

This article describes an issue that occurs when you try to create a VHDX virtual hard disk on a Windows RT 8.1, Windows 8.1, or Windows Server 2012 R2-based Hyper-V host. The issue is resolved in hotfix 2965471 that is described in this article, and it has a prerequisite.

↑ Back to the top


Symptoms

Consider the following scenario:

  • You have Hyper-V running on a Windows RT 8.1, Windows 8.1, or Windows Server 2012 R2-based computer.
  • You try to create a fixed-size VHDX virtual hard disk on a Server Message Block (SMB) share.
In this scenario, the speed of creating the VHDX virtual hard disk is slow. Therefore, it may take a long time to finish the initialization.

↑ Back to the top


Cause

This issue occurs because of limitations in the current by-default design. 

↑ Back to the top


Resolution

To resolve this issue, install the hotfix that is described in this article. 

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix Download Available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix Download Available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must first install the update 2919355 on Windows 8.1 or Windows Server 2012 R2. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

2919355 Windows RT 8.1, Windows 8.1, and Windows Server 2012 R2 Update April, 2014

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.
File information
The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows 8.1 and Windows Server 2012 R2 file information and notes
Important Windows 8.1 hotfixes and Windows Server 2012 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 8.1/Windows Server 2012 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:

    VersionProductMilestoneService branch
    6.3.960 0.17xxxWindows 8.1 and Windows Server 2012 R2RTMGDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information" section. MUM, MANIFEST, and the associated security catalog (.cat) files, are very important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 8.1
File nameFile versionFile sizeDateTimePlatform
Ntfs.sys6.3.9600.171111,679,19230-Apr-201410:05x86
For all supported x64-based versions of Windows 8.1 and of Windows Server 2012 R2
File nameFile versionFile sizeDateTimePlatform
Ntfs.sys6.3.9600.171112,012,50430-Apr-201411:08x64
For Windows RT 8.1
File nameFile versionFile sizeDateTimePlatform
Ntfs.sys6.3.9600.171111,492,83230-Apr-201408:55Not applicable


↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates.

Additional file information

Additional file information for Windows 8.1 and for Windows Server 2012 R2

Additional files for all supported x86-based versions of Windows 8.1
File propertyValue
File nameX86_41ec98c5f78e45bc6d2d37fa94a3ae54_31bf3856ad364e35_6.3.9600.17111_none_804cb7f5695e3c4f.manifest
File versionNot applicable
File size692
Date (UTC)01-May-2014
Time (UTC)19:58
File nameX86_microsoft-windows-ntfs_31bf3856ad364e35_6.3.9600.17111_none_3b598246384f3e88.manifest
File versionNot applicable
File size16,005
Date (UTC)30-Apr-2014
Time (UTC)10:23
Additional files for all supported x64-based versions of Windows 8.1 and of Windows Server 2012 R2
File propertyValue
File nameAmd64_99fa5e94437b4df4ffc46187a916fe06_31bf3856ad364e35_6.3.9600.17111_none_ac9534d3d6552553.manifest
File versionNot applicable
File size696
Date (UTC)01-May-2014
Time (UTC)20:01
File nameAmd64_microsoft-windows-ntfs_31bf3856ad364e35_6.3.9600.17111_none_97781dc9f0acafbe.manifest
File versionNot applicable
File size16,011
Date (UTC)30-Apr-2014
Time (UTC)12:37
Additional files for Windows RT
File propertyValue
File nameArm_42f2a49e262b1783612735add656849c_31bf3856ad364e35_6.3.9600.17111_none_c6646d209de04888.manifest
File versionNot applicable
File size692
Date (UTC)01-May-2014
Time (UTC)20:00
File nameArm_microsoft-windows-ntfs_31bf3856ad364e35_6.3.9600.17111_none_3b5bf49e384c5d4e.manifest
File versionNot applicable
File size16,005
Date (UTC)30-Apr-2014
Time (UTC)11:05

↑ Back to the top


Keywords: kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbexpertiseadvanced, kb

↑ Back to the top

Article Info
Article ID : 2965471
Revision : 1
Created on : 1/7/2017
Published on : 6/16/2014
Exists online : False
Views : 325