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Third-party VPN client stops Internet connectivity in Windows 7 SP1 or Windows Server 2008 R2 SP1


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have a computer that is running Windows 7 Service Pack 1 (SP1) or Windows Server 2008 R2 SP1.
  • You have a third-party VPN solution deployed.
  • You connect your computer to the VPN server.
In this scenario, the network state for the VPN adapter is "No Internet Access." Additionally, some applications may not work properly.

For example, when you press F1 to open Help in Microsoft Office 2013 on the computer, you receive an error message that states the computer is not connected to the Internet, and the Help window is not displayed.

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Cause

This issue occurs because of a code error in the Network Connectivity Status Indicator (NCSI). In this situation, an incorrect connection status is reported. This issue also affects applications that read the network connection status through NCSI.

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Resolution

To resolve this issue, install the hotfix that is described in this article.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows 7 Service Pack 1 (SP1) or Windows Server 2008 R2 SP1.

For more information about how to obtain a Windows 7 or Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To apply this hotfix, you do not have to make any changes to the registry.

Restart requirement

You may have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.
File information
The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.

Windows 7 and Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information" section. MUM, MANIFEST, and the associated security catalog (.cat) files, are very important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 7 and Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Ncsi.dll6.1.7601.22676162,30406-May-201408:36x86
Nlaapi.dll6.1.7601.2213752,22418-Oct-201219:37x86
Nlasvc.dll6.1.7601.22137242,17618-Oct-201219:37x86
Nlasvc.ptxmlNot Applicable2,49413-Jul-200920:54Not Applicable
For all supported x64-based versions of Windows 7 and Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Ncsi.dll6.1.7601.22676223,74406-May-201409:17x64
Nlaapi.dll6.1.7601.2213770,65618-Oct-201220:31x64
Nlasvc.dll6.1.7601.22137303,10418-Oct-201220:31x64
Nlasvc.ptxmlNot Applicable2,49418-Oct-201214:47Not Applicable
Ncsi.dll6.1.7601.22676162,30406-May-201408:36x86
Nlaapi.dll6.1.7601.2213752,22418-Oct-201219:37x86
Ncsi.dll6.1.7601.22676162,30406-May-201408:36x86
Nlaapi.dll6.1.7601.2213752,22418-Oct-201219:37x86
Wow64_nlasvc.ptxmlNot Applicable2,49413-Jul-200920:54Not Applicable
For all supported IA-64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Ncsi.dll6.1.7601.22676485,88806-May-201408:12IA-64
Nlaapi.dll6.1.7601.22676156,67206-May-201408:12IA-64
Nlasvc.dll6.1.7601.22137603,13618-Oct-201219:33IA-64
Nlasvc.ptxmlNot Applicable2,49418-Oct-201214:40Not Applicable
Ncsi.dll6.1.7601.22676162,30406-May-201408:36x86
Nlaapi.dll6.1.7601.2213752,22418-Oct-201219:37x86
Wow64_nlasvc.ptxmlNot Applicable2,49413-Jul-200920:54Not Applicable

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows 7 and Windows Server 2008 R2

Additional files for all supported x86-based versions of Windows 7 and Windows Server 2008 R2
File nameX86_f4354c425e59b2ede4a230386c2d74b9_31bf3856ad364e35_6.1.7601.22670_none_1cdb22a30523ee32.manifest
File versionNot Applicable
File size737
Date (UTC)01-May-2014
Time (UTC)06:52
File nameX86_microsoft-windows-n..tion_service_iasnap_31bf3856ad364e35_6.1.7601.22670_none_7bc6cfc8ccb88da8.manifest
File versionNot Applicable
File size2,311
Date (UTC)30-Apr-2014
Time (UTC)04:11
Additional files for all supported x64-based versions of Windows 7 and Windows Server 2008 R2
File nameAmd64_09472eae93567d1d23d9cf369122e8cb_31bf3856ad364e35_6.1.7601.22676_none_3ce14d144c58dc45.manifest
File versionNot Applicable
File size1,038
Date (UTC)06-May-2014
Time (UTC)11:59
File nameAmd64_4671b0e70f95ce7250a809b2470760d8_31bf3856ad364e35_6.1.7601.22676_none_eab32a6543785ecd.manifest
File versionNot Applicable
File size698
Date (UTC)06-May-2014
Time (UTC)11:59
File nameAmd64_50be71dbf65d475254073eabf637f5a7_31bf3856ad364e35_6.1.7601.22676_none_460df648e928d7dc.manifest
File versionNot Applicable
File size709
Date (UTC)06-May-2014
Time (UTC)11:59
File nameAmd64_aa3135c083fd77cb14d97927242ed59f_31bf3856ad364e35_6.1.7601.22676_none_ba91ec8299e47b22.manifest
File versionNot Applicable
File size698
Date (UTC)06-May-2014
Time (UTC)11:59
File nameAmd64_microsoft-windows-nlasvc_31bf3856ad364e35_6.1.7601.22676_none_c5f6a2453ad66365.manifest
File versionNot Applicable
File size51,834
Date (UTC)06-May-2014
Time (UTC)12:26
File nameWow64_microsoft-windows-nlasvc-servercore_31bf3856ad364e35_6.1.7601.22676_none_36d6c3ae14f4c741.manifest
File versionNot Applicable
File size2,566
Date (UTC)06-May-2014
Time (UTC)12:26
File nameWow64_microsoft-windows-nlasvc_31bf3856ad364e35_6.1.7601.22676_none_d04b4c976f372560.manifest
File versionNot Applicable
File size50,099
Date (UTC)06-May-2014
Time (UTC)12:26
Additional files for all supported IA-64-based versions of Windows Server 2008 R2
File nameIa64_8387e03dff549406312fbcd443f9b8fc_31bf3856ad364e35_6.1.7601.22676_none_cb6565d6787d34cd.manifest
File versionNot Applicable
File size1,036
Date (UTC)06-May-2014
Time (UTC)11:59
File nameIa64_microsoft-windows-nlasvc_31bf3856ad364e35_6.1.7601.22676_none_69d9aab78276fb2b.manifest
File versionNot Applicable
File size51,832
Date (UTC)06-May-2014
Time (UTC)12:20
File nameWow64_microsoft-windows-nlasvc_31bf3856ad364e35_6.1.7601.22676_none_d04b4c976f372560.manifest
File versionNot Applicable
File size50,099
Date (UTC)06-May-2014
Time (UTC)12:20

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Keywords: kb, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbexpertiseinter

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Article Info
Article ID : 2964643
Revision : 1
Created on : 1/7/2017
Published on : 6/11/2014
Exists online : False
Views : 198