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The system or application freezes in a Windows Embedded POSReady 2009-based device


View products that this article applies to.

Symptoms

Assume that you have a device that is running Windows Embedded POSReady 2009. You put the device in idle state for a long time. Or, you frequently change the default registry key in the following registry path:HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Network\ConnectionsIn this situation, the operating system or an application may freeze in the device. When this issue occurs, you have to restart the device to recover the system.

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Cause

This issue occurs because the allocated memory is not freed in the Network Connections (Netman) service. Therefore, a memory leak occurs in the system.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix Download Available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, go to the following Microsoft website: Note The "Hotfix Download Available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this update, you must have Windows Embedded POSReady 2009 installed on the device.

Restart requirement

You must restart the computer after you apply this hotfix.

Update replacement information

This update does not replace a previously released hotfix.
File information
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Windows XP file information notes

  • In addition to the files that are listed in these tables, this hotfix also installs an associated security catalog file (KBnumber.cat) that is signed with a Microsoft digital signature.
For all supported x86-based versions of Windows XP
File nameFile versionFile sizeDateTimePlatform
Netman.dll5.1.2600.6557197,63225-Apr-201410:58x86

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbexpertiseadvanced, kbsurveynew, kb

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Article Info
Article ID : 2963522
Revision : 1
Created on : 1/7/2017
Published on : 6/11/2014
Exists online : False
Views : 192