Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Surface Pro 2 devices intermittently cannot boot past the UEFI screen


View products that this article applies to.

Symptoms

After an update released in March 2014 is installed, a very small number of Surface Pro 2 devices may become unable to boot past the UEFI screen, or the device may display a red screen and not boot any further. This behavior will occur intermittently when the device is restarted.

↑ Back to the top


Cause

This problem occurs because of a negative interaction between new libraries in the March 2014 UEFI update, and hardware components on a very small percentage of Surface Pro 2 devices. This interaction results in a timing issue in which the hardware component is not ready for the instructions that it receives from the UEFI, and this results in the boot process being unable to continue. Subtle differences in hardware component tolerances cause this problem to occur more frequently on some devices.

↑ Back to the top


Resolution

To prevent this issue from occurring, install the updated UEFI package available at the following URL:

http://download.microsoft.com/download/5/7/A/57A4F5B1-FB4B-478A-B780-7A834B24C835/May 2014 Pro 2 FW.zip

To install this update, you must first boot the device into Windows. If your device is experiencing the problem described above, you may have to restart multiple times in order to boot correctly into Windows. After you have booted into Windows, download the package from the link above or copy the file to the Surface device over the network connection, or by using external USB media.

After the file has been copied to the device, follow these steps:
  1. Extract all files in the May 2014 Pro 2 FW.zip file to a folder on the hard disk of the device.
  2. Open Device Manager (You can press the Windows Key + X on your keyboard, or search for this by using the Start Screen) 
  3. Select Firmware Node.
  4. Right-click Surface Pro UEFI, and then select Update Driver Software…
  5. Select Browse my computer for driver software, then Let me pick from a list…, and then Have Disk.
  6. In the extracted files, browse to \May 2014 Pro 2 FW\UEFI\2.04.0750\SurfaceProUEFI.inf and press OKCloseNext, and then Close. Do not restart when you are prompted.

    Note  You can restart between each installation without causing any problems on the device. However you should install both updates in order to make sure functionality of the Surface Pro 2 device is optimal.
  7. Right-click Surface Pro Embedded Controller, and then select Update Driver Software…
  8. Select Browse my computer for driver software, then Let me pick from a list…, and then Have Disk.
  9. In the extracted files, browse to \May 2014 Pro 2 FW\EC\24.01.50\SurfaceProEC.inf and press OKCloseNext, and then Close.
  10. Restart when you are prompted.

Note During restart (while the Surface logo is displayed) the message, Please wait while we install a system update will be displayed briefly.

Note  If you cannot boot into Windows, contact Microsoft Surface hardware support for assistance by calling 800-Microsoft.

↑ Back to the top


Keywords: kbsurveynew, kbtshoot, kbexpertiseinter, kbportal388, kb, kbportal421

↑ Back to the top

Article Info
Article ID : 2963062
Revision : 3
Created on : 7/19/2019
Published on : 7/20/2019
Exists online : False
Views : 252