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System crashes during I/O traffic after you install a Host Bus Adapter on a computer that's running Windows Server 2008 R2


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have a computer that's running Windows Server 2008 R2.
  • You install a Host Bus Adapter (HBA) that supports concurrent channels on the computer.
  • You start I/O traffic on the HBA.

In this scenario, the system crashes during I/O traffic.

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Cause

This problem occurs for miniports that opt into support for concurrent channels in Storport. In this situation, there's a race condition in which Storport tries to access memory that has already been freed, and this causes the system to crash.

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Resolution

After you apply this hotfix, the race condition in Storport is fixed. Memory that has already been freed is no longer affected.

Hotfix information

A supported hotfix is available from Microsoft Support. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, go to the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Service Pack 1 for Windows 7 or Windows Server 2008 R2 installed.



Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any previously released hotfix.

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File information

For a list of the files that are provided in this update, download the file information for this update 2957775.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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References

Learn about the terminology that Microsoft uses to describe software updates.

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Keywords: kb, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbexpertiseinter, kbsurveynew, kbbug

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Article Info
Article ID : 2957775
Revision : 3
Created on : 9/20/2018
Published on : 9/21/2018
Exists online : False
Views : 182