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The FSRM UI stops responding when there are many storage reports to monitor on a server that is running Windows Server 2012 R2


View products that this article applies to.

Symptoms

On a server that is running Windows Server 2012 R2, you view the Storage Reports Management node of the File Server Resource Manager (FSRM) snap-in in Microsoft Management Console (MMC). When the number of storage reports to monitor is sufficiently large, a CPU spike can occur on the server and performance significantly degrades.

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Cause

By default, the FSRM MMC snap-in File Reports status is refreshed every minute. This is designed for only a few reports. Generating lots of reports may cause the FSRM UI to stop responding.

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Resolution

To resolve this problem, apply this hotfix to the computer that is running Microsoft Management Console.

Hotfix information

A supported hotfix is available from Microsoft Support. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, go to the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this update, you must first have update 2919355 installed on Windows 8.1 or Windows Server 2012 R2.

Registry information

After you apply this hotfix, you can configure the following registry value to control the time interval of between each FSRM MMC snap-in File Reports status refresh:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SrmReports\FsrmGuiRefreshIntervalInMilliseconds

Set this subkey to a significantly large value in milliseconds as per your requirements. If this registry value is greater than or equal to 0x7fffffff, the File Reports status refresh is disabled completely.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any previously released hotfix.

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File information
The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.

Windows 8.1 and Windows Server 2012 R2 file information and notes

Important Windows 8.1 and Windows Server 2012 R2 hotfixes are included in the same packages. However, only "Windows 8.1" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 8.1" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, milestone (RTM,SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.

    VersionProductMilestoneService branch
    6.3.960 0.17 xxxWindows 8.1 and Windows Server 2012 R2RTMGDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows 8.1 and Windows Server 2012 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 8.1
File nameFile versionFile sizeDateTimePlatform
Srmgui.dll6.3.9600.174753,242,49629-Oct-201402:22x86
For all supported x64-based versions of Windows 8.1 and Windows Server 2012 R2
File nameFile versionFile sizeDateTimePlatform
Srmgui.dll6.3.9600.174753,242,49629-Oct-201403:07x86

Additional file information for Windows 8.1 and for Windows Server 2012 R2

Additional files for all supported x86-based versions of Windows 8.1
File nameMsil_srmgui_31bf3856ad364e35_6.3.9600.17475_none_9bbca9ac7f3cd337.manifest
File versionNot applicable
File size8,202
Date (UTC)29-Oct-2014
Time (UTC)02:41
File namePackage_1_for_kb2957701~31bf3856ad364e35~x86~~6.3.1.0.mum
File versionNot applicable
File size1,804
Date (UTC)29-Oct-2014
Time (UTC)20:55
File namePackage_for_kb2957701_rtm_gm~31bf3856ad364e35~x86~~6.3.1.0.mum
File versionNot applicable
File size1,405
Date (UTC)29-Oct-2014
Time (UTC)20:55
File namePackage_for_kb2957701_rtm~31bf3856ad364e35~x86~~6.3.1.0.mum
File versionNot applicable
File size1,468
Date (UTC)29-Oct-2014
Time (UTC)20:55
File nameX86_8fc308f6f673fc7c6e359e401e6b2267_31bf3856ad364e35_6.3.9600.17475_none_a6095287237a9616.manifest
File versionNot applicable
File size677
Date (UTC)29-Oct-2014
Time (UTC)20:55
Additional files for all supported x64-based versions of Windows 8.1 and Windows Server 2012 R2
File nameAmd64_8fc308f6f673fc7c6e359e401e6b2267_31bf3856ad364e35_6.3.9600.17475_none_0227ee0adbd8074c.manifest
File versionNot applicable
File size679
Date (UTC)29-Oct-2014
Time (UTC)20:55
File nameMsil_srmgui_31bf3856ad364e35_6.3.9600.17475_none_9bbca9ac7f3cd337.manifest
File versionNot applicable
File size8,202
Date (UTC)29-Oct-2014
Time (UTC)04:28
File namePackage_1_for_kb2957701~31bf3856ad364e35~amd64~~6.3.1.0.mum
File versionNot applicable
File size2,010
Date (UTC)29-Oct-2014
Time (UTC)20:55
File namePackage_for_kb2957701_rtm_gm~31bf3856ad364e35~amd64~~6.3.1.0.mum
File versionNot applicable
File size1,413
Date (UTC)29-Oct-2014
Time (UTC)20:55
File namePackage_for_kb2957701_rtm~31bf3856ad364e35~amd64~~6.3.1.0.mum
File versionNot applicable
File size1,674
Date (UTC)29-Oct-2014
Time (UTC)20:55

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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References

Learn about the terminology that Microsoft uses to describe software updates.

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Keywords: kb, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbexpertiseinter, kbsurveynew, kbbug

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Article Info
Article ID : 2957701
Revision : 1
Created on : 1/7/2017
Published on : 12/22/2014
Exists online : False
Views : 203