Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

"One of your object libraries (|) is missing or damaged" error when you open files in Word or Excel


View products that this article applies to.

Symptoms

When you open a Microsoft Word document or a Microsoft Excel workbook, you receive the following error:

One of your object libraries (|) is missing or damaged

↑ Back to the top


Cause

This problem occurs when you have a 32-bit version of Office 2010 installed and also have the 64-bit version of the Microsoft Access Database Engine 2010 installed.

This combination of products is not supported because these products do not have the same "bitness."

↑ Back to the top


Resolution

To resolve this issue, follow these steps:
  1. Close any Office programs that are running.
  2. In Control Panel, open one of the following control panel items, based on your version of Windows.
    • Windows 8, Windows 7, or Windows Vista

      Programs and Features
    • Windows XP

      Add or Remove Programs
     
  3. In the list of installed products, select Microsoft Access Database Engine 2010, and then click Uninstall. (In Windows XP, click Remove.)
  4. After Microsoft Access Database Engine 2010 is uninstalled, select your Microsoft Office 2010 product in the list of installed products, and then click Change.
  5. Click Repair, and then click Continue.
  6. After your Office installation is repaired, restart your Office program.

↑ Back to the top


More Information

The Microsoft Access Database Engine 2010 Redistributable may be installed by a third-party software product, or you may have unintentionally installed it from the Microsoft Download site at the following location:

There are 32-bit and 64-bit versions of the Microsoft Access Database Engine 2010 Redistributable, and you have to install the version that matches the "bitness" of your Office installation. To determine the "bitness" of your Office installation, follow these steps:
  1. Start any Office program.
  2. On the File menu, click Help.
  3. On the right side of the Help section, notice the "bitness" of your Office installation under About Microsoft <application name>:

↑ Back to the top


Keywords: kb

↑ Back to the top

Article Info
Article ID : 2956215
Revision : 1
Created on : 1/7/2017
Published on : 4/2/2014
Exists online : False
Views : 441