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DNS query fails if you use BIND DNS together with Windows DNS in Windows Server 2008 R2 SP1 or Windows Server 2012 R2


View products that this article applies to.

Symptoms

If you run a DNS query for certain records by using Berkeley Internet Name Domain (BIND) DNS together with Internet-facing Windows DNS in Windows Server 2008 R2 Service Pack 1 (SP1) or Windows Server 2012 R2, the query may fail.

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Cause

This problem occurs because Windows DNS does not update the resource record correctly.

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Resolution

To resolve this issue for Windows Server 2012 R2, install update rollup 2967917. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

2967917 July 2014 update rollup for Windows RT 8.1, Windows 8.1, and Windows Server 2012

Hotfix information

A supported hotfix is available from Microsoft Support. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, go to the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix for Windows Server 2008 R2, you must have Service Pack 1 installed.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any previously released hotfix.

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File information
The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.

Windows Server 2008 R2 file information and notes

Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.

    VersionProductSR_LevelService branch
    6.1.760
    1.
    22xxx
    Windows Server 2008 R2SP1LDR
  • GDR service branches contain only those fixes that are widely released to address widespread, extremely important issues. LDR service branches contain hotfixes in addition to widely released fixes.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Cache.dnsNot applicable3,19805-Nov-201001:52Not applicable
Dns.exe6.1.7601.22709700,92804-Jun-201402:34x64
Dnsserver.events.xmlNot applicable60905-Nov-201001:52Not applicable

Additional file information for Windows Server 2008 R2

Additional files for all supported x64-based versions of Windows Server 2008 R2
File propertyValue
File nameAmd64_6c48ee10b436947e506ec63b85e79a15_31bf3856ad364e35_6.1.7601.22709_none_95fca3ff343c867f.manifest
File versionNot applicable
File size710
Date (UTC)04-Jun-2014
Time (UTC)05:10
PlatformNot applicable
File nameAmd64_microsoft-windows-dns-server-service_31bf3856ad364e35_6.1.7601.22709_none_acc5442c06453ca0.manifest
File versionNot applicable
File size158,131
Date (UTC)04-Jun-2014
Time (UTC)03:02
PlatformNot applicable

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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References

Learn about the terminology that Microsoft uses to describe software updates.

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Keywords: kb, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbdns, kbexpertiseinter, kbsurveynew, kbbug

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Article Info
Article ID : 2954978
Revision : 1
Created on : 1/7/2017
Published on : 7/21/2014
Exists online : False
Views : 266