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When communicator delivery option is set to Both, managers only receive one email notification for documents awaiting approval


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Symptoms

In Employee and Resource Maintenance (PA.EMP.00), when a manager has Send Email To set to Both, you notice that the manager only receives an email for the first employee to complete a timecard.   They do not receive an email for later employees who complete their timecards.

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Cause

The communicator trigger that is responsible for sending the emails only executes on an insert of a new message.  With the Send Email To option set to Both, later timecard completions only update the existing PJCOMMUN record instead of inserting a new one.   Because the existing message is only updated the communicator trigger does not execute and no email notification is sent.

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Resolution

Consider changing the Send Email To option to Mail instead of Both.   Or the manager can view and delete their communicator messages in the View Messages (CO.CMD.00) screen or in the Communicator web part in Business Portal.   As soon as the existing message is deleted, the manager will receive an email the next time that an employee completes a timecard.

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Keywords: kbmbsmigrate, kbmbspartner, kbsurveynew, kb

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Article Info
Article ID : 2954212
Revision : 2
Created on : 2/3/2017
Published on : 2/3/2017
Exists online : False
Views : 273