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PDF Files Are Not Returned from the ISA Server Cache


View products that this article applies to.

This article was previously published under Q295386

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Symptoms

When you open Adobe Acrobat PDF documents, Internet Security and Acceleration (ISA) Server saves them to the cache. However, subsequent requests for the same documents are not served from the cache, but are instead retrieved again from the original source.

The Web proxy logs show that the PDF documents are coming from the intranet (an inet entry in the log, rather than a cache or vcache entry).

The Cachedir.exe utility that is included with the ISA Server CD-ROM shows that the PDF documents are actually in the cache. However, when the client makes the request, ISA Server retrieves them from the intranet. Note that for all other matters, the ISA Server cache appears to work well.

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Cause

When a PDF file is requested, the Web browser (loading the Acrobat reader when a PDF file is requested) is asking for two requests for each file. The first request is a regular request, and it is returned correctly from the cache. The second request is a range request that contains an "If-Range: " header with the previous request's ETag. ISA Server does not support headers with ETags from the cache (If-Range, If-None-Match, and so on), so this request is forwarded to the Internet.

Example

The cache receives a file with Etag "1234567". The client then asks for that file with the If-Match = "1234567". The cache passes this on to the server, instead of answering itself.

ETag/If-Match/If-None-Match are not implemented in the ISA Web proxy. All requests that have If-Match or If-None-Match without an If-Modified-Since header are passed through the proxy unmodified so that they "work" properly.

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Resolution

To resolve this problem, obtain the latest service pack for ISA Server. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
313139 How to Obtain the Latest Internet Security and Acceleration Server 2000 Service Pack
A supported fix is also available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem.

The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Version        File name     Platform
   -------------------------------------
   3.0.1200.66    W3proxy.exe   Intel
				

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was corrected in ISA Server SP1.

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More information



If you notice that some requests are still going to the Web instead of being served from the cache, you can correct this behavior by changing the caching properties in Routing Rules. You can configure ISA Server to return any version of the object from the cache regardless of the request headers. To do so, enable the "Any version of the object if none exists, retrieve the request using the route defined in the Action tab." feature in Routing Rule Properties on the Cache tab.

The hotfix and service pack that are described in this article serve PDF files that are saved in the cache.

The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

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Keywords: KB295386, kbprb, kbenv, kb3rdparty, kbhotfixserver, kbqfe, kbproductlink

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Article Info
Article ID : 295386
Revision : 6
Created on : 10/26/2007
Published on : 10/26/2007
Exists online : False
Views : 360