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Windows Server 2012 restarts unexpectedly and Application Error 1000 is logged in the Application log


View products that this article applies to.

Symptoms

You have a server that is running Windows Server 2012 as a Domain Controller. The Domain Controller restarts unexpectedly and an error message that resembles the following is logged in the Application log:

Application Error 1000
faulting application: lsass.exe, version: 6.2.9200.16420, time stamp: 0x505a9bdf
faulting module: schannel.DLL, version: 6.2.9200.16722, time stamp: 0x5240bf32
exception code : 0xc0000005
fault offset: 0x00000000000104ee
process id: 0x278
application start time: 0x01cee5dc027296b6
faulting application path: C:\Windows\system32\lsass.exe
faulting module path: C:\Windows\system32\schannel.DLL
report ID: 287f7125-51d6-11e3-93fe-2c59e5473471

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Cause

This problem occurs because Domain Controllers do not handle some security context correctly. lsass.exe refers to a NULL pointer if no memory is allocated for the pOutput->pBuffers[0].pvBuffer function or if the ASC_REQ_ALLOCATE_MEMORY flag is set to request LSA to allocate memory.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft Support. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, go to the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows 8 or Windows Server 2012.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any previously released hotfix.

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File information

For a list of the files that are provided in this update, download the file information for this update 2952379.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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References

Learn about the terminology that Microsoft uses to describe software updates.

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Keywords: kbbug, kbsurveynew, kbexpertiseinter, kbautohotfix, kbhotfixserver, kbqfe, kb, kbfix

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Article Info
Article ID : 2952379
Revision : 1
Created on : 1/7/2017
Published on : 11/20/2016
Exists online : False
Views : 268