Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Setup stops with error message: A problem has been encountered while loading the setup components


View products that this article applies to.

This article was previously published under Q294814

↑ Back to the top


Symptoms

When you try to run the Microsoft Exchange 2000 Server Setup program, the Setup program may stop responding, and you receive the following error message:
A problem has been encountered while loading the setup components. Canceling Setup
Additionally, the Exchange Server Setup Progress.log file may contain information that is similar to the following:
[11:46:30]  ************** Beginning Setup run **************
[11:46:30] Starting Exchange 4417 setup on Windows 2000 5.0.2195.Service Pack 1 at 11:46:30 03/27/2001
[11:46:30] Entering CFileManager::ScInit
[11:46:30] Entering CFileManager::ScAutoDetectDirectoryLocations
[11:46:30]  CService::ScQueryServiceConfig
           Error code 0XC0070424 (1060): The specified service does not exist as an installed service.
				

↑ Back to the top


Cause

This problem occurs when the Setup program fails while checking the Windows Management Instrumentation (WMI) subsystem and there is a problem with the WMI or the Web-based enterprise management (WBEM) subsystem on the computer on which you are installing Exchange Server.

↑ Back to the top


Resolution

For more information about how to troubleshoot WMI problems on Microsoft Windows XP-based computers, click the following article number to view the article in the Microsoft Knowledge Base:
875605 � How to troubleshoot WMI-related issues in Windows XP Service Pack 2

↑ Back to the top


More information

To verify that you are having WMI or WBEM problems, use one or both of the following methods.

Method 1

  1. Click Start, point to Programs, click Administrative Tools, and then click Services.
  2. Ensure the Windows Management Instrumentation service is present. If it is not, there is a problem with this operating system.

Method 2

  1. Right-click the My Computer icon on your desktop, and then click Manage.
  2. Expand Services and Applications.
  3. Right-click WMI Control, and then click Properties. You should receive the following message:
    Successfully Connected to: local computer.
    If you do not receive this message, there is a problem with the operating system.

↑ Back to the top


Keywords: KB294814, kbprb, kberrmsg

↑ Back to the top

Article Info
Article ID : 294814
Revision : 4
Created on : 2/27/2007
Published on : 2/27/2007
Exists online : False
Views : 298