Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Missing Start screen tiles when you deploy Windows 8.1 by using the Local Administrator account


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You are installing Windows 8.1 on a computer.
  • You enable the Local Administrator account by using unattended.xml, and then you log onto that account in order to perform image customization.
  • Or, you boot into audit mode in order to perform image customization (which actually uses the Local Administrator account).
In this scenario, when users arrive at the Start screen after the Out-of-Box Experience (OOBE) process, they see only five app tiles instead of seeing the default Start screen that contains all preinstalled app tiles.

↑ Back to the top


Cause

This problem occurs because of some registry keys related to app registration that are not cleaned up correctly during the media refresh process. These registry keys cause problems for app registration tasks for end-users during the first logon.

↑ Back to the top


Workaround

To work around this problem, you have to clean up the AppReadiness registry keys. To do this, use one of the following methods.

Method 1

Mount the installation media and the HKLM registry hive offline, and then delete the AppReadiness registry keys. To do this, run the following commands from the command prompt:
dism.exe /mount-image /imagefile:< path to WIM > /index:< index > /mountdir:c:\temp\mount

reg load HKLM\TempFix C:\temp\mount\Windows\System32\Config\Software

reg delete HKLM\TempFix\Microsoft\Windows\CurrentVersion\AppReadiness\S-1-5-18 /f

reg delete HKLM\TempFix\Microsoft\Windows\CurrentVersion\AppReadiness\S-1-5-21-1445756777-203018680-2844431724-500 /f

reg unload HKLM\TempFix

dism.exe /unmount-image /mountdir:c:\temp\mount /commit
Method 2

Boot into the installed operating system, stop the AppReadiness service, delete the AppReadiness registry keys, and restart the computer.

To stop the AppReadiness service and delete the AppReadiness registry keys, run the following commands from the command prompt:
sc stop AppReadiness

reg delete HKLM\Software\Microsoft\Windows\CurrentVersion\AppReadiness\S-1-5-18 /f

reg delete HKLM\Software\Microsoft\Windows\CurrentVersion\AppReadiness\S-1-5-21-1445756777-203018680-2844431724-500 /f


↑ Back to the top


More Information

Registry keys related to per-user app installation are not cleaned up as needed after audit mode customizations. As a result, in-box apps fail to install, which causes the five-tile Start screen layout.

This problem is scheduled to be resolved in the next media refresh.

↑ Back to the top


Keywords: kbsurveynew, kbtshoot, kbexpertiseinter, kb

↑ Back to the top

Article Info
Article ID : 2947485
Revision : 1
Created on : 1/7/2017
Published on : 8/22/2014
Exists online : False
Views : 475