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FP2002: Usage Analysis Does Not Process Log Files; or, Error Message: Usage Processing Failed to Complete Normally


View products that this article applies to.

This article was previously published under Q294395

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Symptoms

When you run usage analysis on a Microsoft Internet Information Services (IIS) 5.0 Web server, one of the following symptoms may occur:
  • Usage analysis does not process the log files correctly.

    -or-
  • You receive the following error message:
    Usage processing failed to complete normally.

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Cause

These problems can occur if process accounting is turned on for a virtual server in IIS.

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Workaround

To work around this issue, you must first determine whether process accounting logging is turned on for the virtual server in question. To do this, follow these steps:
  1. Open the Internet Services Manager. To do this, follow these steps:
    1. Click Start, point to Programs, and then click Administrative Tools.
    2. Click Internet Services Manager.
  2. Right-click the virtual server in question, and then select Properties.
  3. On the Web Site tab, set the log format to W3C Extended.
  4. Click the Properties button.
  5. On the General Properties tab, note the log file name, which will be a name like W3SVC1\exyymmdd.log, where
    • W3SVC1 is the virtual server instance. In this case, it is Instance 1, which is typically the Default Web Site.

      This is also the name of the folder under %SystemRoot%\System32\Logfiles, where the log files for this virtual server are kept.
    • Exyymmdd.log is the log file name.

      The naming syntax for log files is defined in Microsoft Knowledge Base article 242898� . For more information, please see the "References" section of this article.
  6. Select the Extended Properties tab.
  7. Scroll down to the bottom. Determine whether any check boxes are selected under the Process Accounting section.

Allow Usage Analysis to Process Your Log Files

NOTE: Both of the following methods require that all process accounting be turned off by using the steps listed earlier in this section to determine whether process accounting is turned on.

Method 1

Remove the process accounting information from the log files. To do this, follow these steps:
  1. Turn off all process accounting options for the virtual server.
  2. Open the folder where the virtual server's log files are kept, using the information listed earlier in this article.
  3. Open the log files for the virtual server, and then search for sections of the log file that look similar to the following:
    #Software: Microsoft Internet Information Services 5.0
    #Version: 1.0
    #Date: 2001-03-17 02:07:12
    #SubComponent: Process Accounting
    #Fields: date time s-event s-process-type s-user-time s-kernel-time s-page-faults s-total-procs s-active-procs s-stopped-procs
    2001-03-17 02:07:12 Periodic-Log All 00.000% 00.000% 0 0 0 0
    					
  4. Remove each process accounting section entirely, and then save the file.

Method 2

Delete the log files for the virtual server in question. To this, follow these steps:
  1. Turn off all process accounting options for the virtual server.
  2. Open the folder where the virtual server's log files are kept, using the steps listed earlier in this section.
  3. Delete all existing log files.

    NOTE: If you delete the log files, there is no way to review your Web server's past Web activity; also, usage analysis cannot process data from previous Web activity.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

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References

For additional information about Microsoft IIS log files, click the article numbers below to view the articles in the Microsoft Knowledge Base:
242898� IIS Log File Naming Syntax
194699� Extended Log File Format Always in GMT

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Keywords: KB294395, kbnofix, kberrmsg, kbbug

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Article Info
Article ID : 294395
Revision : 2
Created on : 2/21/2007
Published on : 2/21/2007
Exists online : False
Views : 443