Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Server Manager shows an incorrect amount of memory on a computer that's running a Generation 2 Virtual Machine


View products that this article applies to.

Symptoms

Server Manager displays an incorrect amount of installed memory in a Generation 2 virtual machine when the random access memory (RAM) that's assigned to the virtual machine is 36,736 megabytes (MB) or more. If the virtual machine is assigned more than 36,736 MB of RAM, Server Manager shows that the system only has 3.88 gigabytes (GB) of RAM installed.

↑ Back to the top


Cause

This problem occurs because of an issue in the Hyper-V virtual machine UEFI firmware.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft Support. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, go to the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2012 R2.



Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any previously released hotfix.

↑ Back to the top


File information

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


References

Learn about the terminology that Microsoft uses to describe software updates.

↑ Back to the top


Keywords: kbbug, kbsurveynew, kbexpertiseinter, kbautohotfix, kbhotfixserver, kbqfe, kb, kbfix

↑ Back to the top

Article Info
Article ID : 2942507
Revision : 1
Created on : 1/7/2017
Published on : 5/14/2014
Exists online : False
Views : 205