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Multiple Overdue Tasks Are Run and Alerts Are Issued for a Short Period


View products that this article applies to.

This article was previously published under Q293863

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Symptoms

On an ISA Server-based computer that has been running for more than 49 days, you may notice one or more of the following symptoms that last for a short duration:
  • Some alerts may be triggered over and over again.
  • Hundreds of LDAP queries each second may be sent to the Active Directory.
  • The creation of ISA log files may stop.
One or more of the following Application Event log entries may be noticed: (Notice that the event log states that the error is occuring several hundred times in the last few hours.)

Event Type:Error
Event Source:Microsoft ISA Server Control
Event Category:None
Event ID:14079
Date:2001.08.25
Time:10:43:24
User:N/A
Computer:GATEKEEPER-1
Description: Due to an unexpected error, the service w3proxy stopped responding to all requests. This occurred 390 time(s) in the past 16:58 hours. Try to stop the service or kill the corresponding process if it does not respond, and start it again. Check the Event Viewer for related error messages.
For more information, see the Help and Support Center located at http://support.microsoft.com.
Event Type:Error
Event Source:Microsoft ISA Server Control
Event Category:None
Event ID:14079
Date:2001.08.25
Time:10:43:24
User:N/A
Computer:GATEKEEPER-1
Description: Due to an unexpected error, the service w3schdwn stopped responding to all requests. This occurred 257 time(s) in the past 16:58 hours. Try to stop the service or kill the corresponding process if it does not respond, and start it again. Check the Event Viewer for related error messages.
For more information, see Help and Support Center at http://support.microsoft.com.
Event Type:Error
Event Source:Microsoft ISA Server Control
Event Category:None
Event ID:14079
Date:2001.08.25
Time:10:43:24
User:N/A
Computer:GATEKEEPER-1
Description: Due to an unexpected error, the service fwsrv stopped responding to all requests. This occurred 262 time(s) in the past 16:58 hours. Try to stop the service or kill the corresponding process if it does not respond, and start it again. Check the Event Viewer for related error messages.
For more information, see Help and Support Center at http://support.microsoft.com

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Cause

This problem can occur because of improper handling of the tick count overlap by the scheduler that is used to raise alerts and manage keep alive signaling. This overlapping happens after every 49 days of continuous running (for the server computer). In this case, the DWORD that is used for storing the tick count overlaps, and this can cause some alerts to be raised over and over again and intense (approximately 190 queries each second) LDAP querying on an Active Directory-integrated ISA Server-based computer for a short period.

The problem occurs because the scheduler checks for overtimed tasks (after a new task is inserted to its list) by comparing the current tick count to the one that is stored in the task. When the tick count overlapps, future tasks that are scheduled (a minute later) are considered to be overtimed, and because of this, are run at once. After the task runs, it is re-inserted into the task list, only to be run again. This can happen at a rate of ten times each second.

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Resolution

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language. The English version of this fix should have the following file attributes or later:
   Date         Time      Version      Size     File name  Platform
   ----------------------------------------------------------------
   Apr 4, 2001  14:13:32  3.0.1200.62  211,216  Msfpc.dll  Intel
				

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Workaround

To work around this problem, restart all of the services:
  1. At a command prompt, type net stop isactrl, and then press ENTER.
  2. Type net start fwsrv, and then press ENTER.
  3. Type net start w3proxy, and then press ENTER.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

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Keywords: KB293863, kbprb, kbfix, kbenv, kbhotfixserver, kbqfe, kbproductlink, kbautohotfix

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Article Info
Article ID : 293863
Revision : 9
Created on : 10/26/2007
Published on : 10/26/2007
Exists online : False
Views : 254