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You receive a "Microsoft Internet Explorer has encountered a problem and needs to close (Pdm.dll)" error message


View products that this article applies to.

Important This article discusses a very specific Internet Explorer crash in older versions of the script debugger (Pdm.dll) that was included with Office 2000 and Visual Studio 6 (pre-SP3 version). If you view the error report details listed in the "Symptoms" section, and Pdm.dll version 6.0.0.8169 is not listed under Module Name, then this article does not apply to you.

If you are experiencing other Internet Explorer issues, such as Internet Explorer hanging, not working, or restarting, please visit the following Microsoft Web site:

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Symptoms

You receive the following error message in Windows Explorer, Internet Explorer, or MSN Explorer:
Microsoft Internet Explorer has encountered a problem and needs to close. We are sorry for the inconvenience.
In the error message, click the click here link at the bottom of the message box. For this particular error, the following error signature information is displayed:

Program Name Program Version Module Name Module Version Offset
------------------------------------------------------------------------
Explorer.exe various Pdm.dll 6.0.0.8169 0001259d
Iexplore.exe various Pdm.dll 6.0.0.8169 0001259d
Netdocs.exe various Pdm.dll 6.0.0.8169 0001259d
Msn6.exe various Pdm.dll 6.0.0.8169 0001259d
If your error signature information does not match this one, this article does not apply to you.

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Cause

This error message occurs when the Pdm.dll file is out of date.

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Resolution

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This resolution requires you either to disable script debugging or to update the Pdm.dll file. If you must have the script debugging capability, you have to update the Pdm.dll file. To update your version of the Pdm.dll file, go to the "Download the updates to the Pdm.dll from the product update Web site" section. Otherwise, to avoid this error, disable script debugging in Internet Explorer. If you are running Windows XP, use Guided Help to disable script debugging. If you are running any other operating system, go to the "Manually disable script debugging" section.

Download Guided Help to automatically disable script debugging

This resolution can only be used with Windows XP. If you are running another operating system, go to the "Manually disable script debugging" section to turn off script debugging in Internet Explorer. If you do not want to disable script debugging, go to the "Download the updates to the Pdm.dll from the product update Web site" section.
Guided Help is available to disable script debugging in Internet Explorer and to visit the appropriate product update Web site. Guided Help can automatically perform the steps for you.

The actions that this Guided Help performs can be undone after Guided Help is finished. To undo this Guided Help, enable script debugging in Internet Explorer.

Requirements to install and to use this Guided Help

  • You must be logged on to Windows by using a computer administrator account to install Guided Help.
  • You must be running Windows XP Home Edition, Windows XP Professional, Windows XP Media Center Edition, or Windows XP Tablet PC Edition to install and to use this Guided Help.
You must first download Guided Help. To start, click the following link:
Download Guided Help

If Guided Help did not work for you, go to the "Manually disable script debugging" section.

Manually disable script debugging

This resolution can be used for all operating systems. If you do not want to disable script debugging, go to the "Download the updates to the Pdm.dll from the product update Web site" section.

To manually disable script debugging in Internet Explorer, follow these steps:
  1. Start Internet Explorer.
  2. On the Tools menu, click Internet Options.
  3. On the Advanced tab, under the Browsing section, click to select the Disable script debugging (Internet Explorer) check box and the Disable script debugging (Other) check box if it is present.
  4. Click OK, and then restart your computer.
If these steps resolved the error message, you are finished.

If these steps did not resolve the error message, go to the "Download the updates to the Pdm.dll from the product update Web site" section.

Download the updates to the Pdm.dll from the product update Web site

This resolution can be used for all operating systems except Windows 98 and Windows Millennium Edition (Me). Use this resolution if you must have the script debugging capability. To repair and use script debugging, you have to update the Pdm.dll file. To update the Pdm.dll file, install the appropriate upgrades that are described in this section.

Note If you are running Windows 98 or Windows Millennium Edition (Me), the following upgrades do not install an updated version of the Pdm.dll file. The only resolution available to you is to upgrade your operating system.

If you are running Microsoft Visual Studio 6.0, upgrade to Microsoft Visual Studio 6.0 Service Pack 5 (SP5) or a later version. To download this upgrade, visit the following Microsoft Web site, click the Service Packs link, and then click the service pack version that you want to download: If you are running the Microsoft Script Debugger in Windows 2000, Windows NT 4.0, Windows Server 2003, or Windows XP, upgrade to a newer version.

Note Although the Script Debugger upgrade is available for these operating systems, it is no longer supported. You can still download and use this upgrade.
 
If these updates resolve the error message, you are finished.

If you still receive the error message after you download and install these updates, go to the “Next Steps” section for information about how to contact Support.

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NEXT STEPS

If the steps in this article did not resolve the error message, you might want to ask someone you know for help, or, you can also use the Microsoft Customer Support Services Web site to find other solutions. Some services that the Microsoft Customer Support Services Web site provides include the following:
  • Searchable Knowledge Base: Search technical support information and self-help tools for Microsoft products.
  • Solution Centers: View product-specific frequently asked questions and support highlights.
  • Other Support Options: Use the Web to ask a question, contact Microsoft Customer Support Services, or provide feedback.
If you continue to have questions after you use these Microsoft Web sites or if you cannot find a solution on the Microsoft Support Services Web site, click the following link to contact Support:

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Article Info
Article ID : 293623
Revision : 5
Created on : 4/30/2020
Published on : 4/30/2020
Exists online : False
Views : 657