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The Windows Azure Pack Service Management Portal does not retrieve cloud settings


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Symptoms

The Microsoft Windows Azure Pack (WAP) Service Management Portal may not retrieve cloud settings from Microsoft System Center 2012 R2 Virtual Machine Manager (VMM 2012 R2), and you may receive the following error message:

Unable to retrieve clouds on VMM server 'SERVERNAME'. Please make sure the server name is correct and try connecting again.

Note By default, the Microsoft Windows Azure Pack (WAP) Service Management Portal is located at http://localhost:30091 on the WAP Admin Server.

The VMM server will be registered in WAP. However, no clouds will be visible, and the VM Clouds item on the left side of the console will not increment.

If System Center 2012 R2 Service Provider Foundation (SPF) debug logging is enabled, it will display an error message that resembles the following:

Component: Core

Activity [Powershell::Invoke, id {6d2e4cf8-b91a-4018-9185-9ad0d03427d1}]
Parent activity [Update, id {be6696b8-8db8-4717-b903-86903c073f11}]
Elapsed: 29ms
Context: {a0d880e8-3355-4926-9518-5f1dc9b09417}

An instance of Stamp with Id = 1daaeaf5-0a79-40e0-a402-1b8cfae3e84c was successfully updated in the database.

SPF's Get-SCSPFStampServerLink script entered. Module: Get-SCSPFStampServerLink.ps1 -StampID: 1daaeaf5-0a79-40e0-a402-1b8cfae3e84c -ServerID: 00000000-0000-0000-0000-000000000000

In this case, a ServerID of all zeros indicates an error in the registration.

If you try to enumerate VMM clouds in SPF by going to https://localhost:8090/SC2012R2/VMM/Microsoft.Management.Odata.svc/Clouds on the SPF server, you will receive an error message that resembles the following:

<?xml version="1.0" encoding="UTF-8"?><m:error xmlns:m="http://schemas.microsoft.com/ado/2007/08/dataservices/metadata"><m:code/><m:message xml:lang="en-US">Error Message: Tenant Administrator not found in DB. Contact your service provider for assistance</m:message><m:innererror><m:message>Tenant Administrator not found in DB. Contact your service provider for assistance</m:message><m:type>Microsoft.SystemCenter.Foundation.Psws.Spf.ScriptException</m:type><m:stacktrace> at Microsoft.SystemCenter.Foundation.Psws.HandleExceptionDecorator.HandleException(Exception exception)</m:stacktrace></m:innererror></m:error>


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Cause

This error can occur if the Administrator "pseudo-tenant" was removed or renamed in SPF. SPF requires this account to be present, to have the "Administrator," and to have an all-zeros (00000000-0000-0000-0000-000000000000) GUID for the SubscriptionID.

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Resolution

To resolve this error and enable the VMM clouds to be successfully registered, follow these steps:
  1. Log on to the SPF server by using an account that is a member of the SPF_Admin local group.
  2. Open an elevated Windows PowerShell window.
  3. Type the following commands, and press Enter after you type each command:
    Import-module spfadmin
    New-SCSPFTenant -Name Administrator -SubscriptionId 00000000-0000-0000-0000-000000000000
  4. Close the WAP Server Management Portal, and then reconnect to it to update all items.

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More Information

There are other possible causes of the "Unable to retrieve clouds on VMM server" error. Determine whether the SPF Administrator tenant exists before you follow the steps in this article.

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Keywords: kb, kbsurveynew, kbprb, kbexpertiseinter

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Article Info
Article ID : 2935175
Revision : 2
Created on : 3/27/2020
Published on : 3/27/2020
Exists online : False
Views : 377