Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

You cannot access DFS folders in Windows Server 2012 R2 or Windows Server 2012


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have a Windows Server 2012 R2 or Windows Server 2012-based server that is running the Distributed File System (DFS) service.
  • You create two DFS namespace folders that have similar names. For example, one is \DFSRoots\ExampleTest\FolderName, the other is \DFSRoots\Example.
  • You restart the DFS service.
In this scenario, the reparse points under the \DFSRoots\ExampleTest\FolderName folder are deleted unexpectedly. Therefore, you cannot access the folder.

↑ Back to the top


Cause

This issue occurs because the method to compare folder names is incorrect.

↑ Back to the top


Resolution

To resolve this issue for Windows Server 2012 R2, install update 2919355.
To resolve this issue for Windows Server 2012, install the hotfix that is described in this article.

Update information for Windows Server 2012 R2

For more information about how to obtain update 2919355, click the following article number to view the article in the Microsoft Knowledge Base:
2919355 Windows RT 8.1, Windows 8.1, and Windows Server 2012 R2 Update April, 2014

Hotfix information for Windows Server 2012

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2012.

Registry information

To apply this hotfix, you do not have to make any changes to the registry.

Restart requirement

You may have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.
File information
The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2012 file information notes
Important Windows 8 and Windows Server 2012 hotfixes are included in the same packages. However, only "Windows 8" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 8" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
    VersionProductMilestoneService branch
    6.2.920 0.20xxxWindows Server 2012RTMLDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2012" section. MUM, MANIFEST and the associated security catalog (.cat) files, are very important to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2012
File nameFile versionFile sizeDateTimePlatform
Dfsn-serverservice-ppdlic.xrm-msNot applicable2,91306-Feb-201402:07Not applicable
Dfssvc.exe6.2.9200.20935398,84805-Feb-201423:36x64

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More Information

For more information about DFS, go to the following Microsoft website:For more information about reparse points, go to the following Microsoft website:For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Server 2012

Additional files for all supported x64-based versions of Windows Server 2012
File propertyValue
File nameAmd64_151ae32f0d8d4ceebcd9caf78c900d33_31bf3856ad364e35_6.2.9200.20935_none_41625f61d967f1a1.manifest
File versionNot applicable
File size710
Date (UTC)06-Feb-2014
Time (UTC)08:42
PlatformNot applicable
File nameAmd64_microsoft-windows-dfsn-serverservice_31bf3856ad364e35_6.2.9200.20935_none_48979df8e6ab598c.manifest
File versionNot applicable
File size64,199
Date (UTC)06-Feb-2014
Time (UTC)02:13
PlatformNot applicable
File nameUpdate.mum
File versionNot applicable
File size1,821
Date (UTC)06-Feb-2014
Time (UTC)08:42
PlatformNot applicable

↑ Back to the top


Keywords: kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbexpertiseadvanced, kb

↑ Back to the top

Article Info
Article ID : 2931974
Revision : 1
Created on : 1/7/2017
Published on : 4/8/2014
Exists online : False
Views : 223