Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

"STOP error code 0x000000D1 (DRIVER_IRQL_NOT_LESS_OR_EQUAL)" when passing fragmented packets without NAT


View products that this article applies to.

Symptoms

If the Network Address Translation (NAT) driver on an Internet Security and Acceleration (ISA) Server-based server is stopped and the data that is being sent outbound is larger than the Maximum Transmission Unit (MTU) setting, fragmented packets pass through ISA Server, which may cause the following error message on a blue screen:
STOP 0x000000D1 (0x0000010e, 0x00000002, 0x00000000, 0xbfee8c70) DRIVER_IRQL_NOT_LESS_OR_EQUAL error code.
When this occurs, the following Event log entry is generated:
Event Type: Information
Event Source: Save Dump
Event Category: None
Event ID: 1001
Date:
Time:
User: N/A
Computer:
Description:
The computer has rebooted from a bugcheck. The bugcheck was: 0x000000d1 (0x0000010e, 0x00000002, 0x00000000, 0xbfee8c70). Microsoft Windows 2000 [v15.2195]. A dump was saved in: %SystemRoot%\MEMORY.DMP.

↑ Back to the top


Cause

The Mspfltex.sys module stops working correctly in such a scenario. The problem can occur when you are using the Firewall client or in the S-NAT configuration.

↑ Back to the top


Resolution

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language. The English version of this fix should have the following file attributes or later:
   Date       Time      Version      Size    File name   
   ------------------------------------------------------
   7/01/2001  11:06:42  3.0.1200.61  41,904  Mspfltex.sys
				

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

↑ Back to the top


More information

It is unusual for the NAT driver to stop without manual intervention. Some other service or problem may have caused the NAT driver to stop. For testing purposes, you can stop the NAT driver by using the following command:
net stop ipnat
The error message might also occur if IP routing (ICMP pass-through) is enabled and a ping (ICMP) packet that is larger than the MTU setting is sent to a remote host.

↑ Back to the top


Keywords: KB293161, kbprb, kbisaserv2000sp1fix, kbfix, kbenv, kbhotfixserver, kbqfe, kbproductlink, kbautohotfix

↑ Back to the top

Article Info
Article ID : 293161
Revision : 3
Created on : 3/2/2012
Published on : 3/2/2012
Exists online : False
Views : 294