Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

The OEMAppID setting does not retrieve user information in Windows 8.1 or Windows Server 2012 R2


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have a computer that is running Windows 8.1 or Windows Server 2012 R2.
  • You use the OEMAppID setting in an Out of Box Experience (OOBE) element within Microsoft-Windows-Shell-Setup.
  • You use this setting to retrieve the information that was entered by a user on the OEM registration page.
In this scenario, the user information is not retrieved.

↑ Back to the top


Cause

This problem occurs because there are no files in the %LocalAppData%\Packages\OEMAppPackageName\LocalState\ folder.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft Support. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, go to the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows 8.1 or Windows Server 2012 R2 installed.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any previously released hotfix.

↑ Back to the top


File information
The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.

Windows 8.1 and Windows Server 2012 R2 file information and notes

Important Windows 8.1 and Windows Server 2012 R2 hotfixes are included in the same packages. However, only "Windows 8.1" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 8.1" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, milestone (RTM,SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.

    VersionProductMilestoneService branch
    6.3.960 0.16xxxWindows 8.1 and Windows Server 2012 R2RTMGDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows 8.1 and Windows Server 2012 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 8.1
File nameFile versionFile sizeDateTimePlatform
Explorer-ppdlic.xrm-msNot Applicable3,10731-Jan-201413:51Not Applicable
Explorer.exe6.3.9600.165232,065,45631-Jan-201413:57x86
For all supported x64-based versions of Windows 8.1 and Windows Server 2012 R2
File nameFile versionFile sizeDateTimePlatform
Explorer-ppdlic.xrm-msNot Applicable3,10731-Jan-201416:08Not Applicable
Explorer.exe6.3.9600.165232,065,45631-Jan-201413:57x86
For all supported ARM-based versions of Windows 8.1
File nameFile versionFile sizeDateTimePlatform
Explorer-ppdlic.xrm-msNot Applicable3,10731-Jan-201411:27Not Applicable
Explorer.exe6.3.9600.165231,955,96831-Jan-201411:30Not Applicable

Additional file information

Additional file information for Windows 8.1 and Windows Server 2012 R2

Additional files for all supported x86-based versions of Windows 8.1
File nameX86_1f5dbd40a37740dc15569ed43161f129_31bf3856ad364e35_6.3.9600.16523_none_530f197e551f404d.manifest
File versionNot Applicable
File size696
Date (UTC)31-Jan-2014
Time (UTC)23:04
SHA-1 hashNot Applicable
MD5 hashNot Applicable
File nameX86_microsoft-windows-explorer_31bf3856ad364e35_6.3.9600.16523_none_e6944ea395263d4e.manifest
File versionNot Applicable
File size27,687
Date (UTC)31-Jan-2014
Time (UTC)14:14
SHA-1 hashNot Applicable
MD5 hashNot Applicable
Additional files for all supported x64-based versions of Windows 8.1 and Windows Server 2012 R2
File nameAmd64_05fd19c9b09b46ddcc92391061649064_31bf3856ad364e35_6.3.9600.16523_none_1ef8aa0eee1884ce.manifest
File versionNot Applicable
File size700
Date (UTC)31-Jan-2014
Time (UTC)22:48
SHA-1 hashNot Applicable
MD5 hashNot Applicable
File nameAmd64_6d9f498c771bfa165db7ea74dfe64653_31bf3856ad364e35_6.3.9600.16523_none_b98c76d23ee13cee.manifest
File versionNot Applicable
File size700
Date (UTC)31-Jan-2014
Time (UTC)22:48
SHA-1 hashNot Applicable
MD5 hashNot Applicable
File nameAmd64_microsoft-windows-explorer_31bf3856ad364e35_6.3.9600.16523_none_42b2ea274d83ae84.manifest
File versionNot Applicable
File size27,691
Date (UTC)31-Jan-2014
Time (UTC)16:34
SHA-1 hashNot Applicable
MD5 hashNot Applicable
File nameWow64_microsoft-windows-explorer_31bf3856ad364e35_6.3.9600.16523_none_4d07947981e4707f.manifest
File versionNot Applicable
File size26,479
Date (UTC)31-Jan-2014
Time (UTC)14:14
SHA-1 hashNot Applicable
MD5 hashNot Applicable
Additional files for all supported ARM-based versions of Windows 8.1
File nameArm_0af984b34d510033b7eb3e5f822447de_31bf3856ad364e35_6.3.9600.16523_none_1ebaf9eb4611e96e.manifest
File versionNot Applicable
File size696
Date (UTC)31-Jan-2014
Time (UTC)23:18
SHA-1 hashNot Applicable
MD5 hashNot Applicable
File nameArm_microsoft-windows-explorer_31bf3856ad364e35_6.3.9600.16523_none_e696c0fb95235c14.manifest
File versionNot Applicable
File size27,899
Date (UTC)31-Jan-2014
Time (UTC)11:47
SHA-1 hashNot Applicable
MD5 hashNot Applicable

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


References

Learn about the terminology that Microsoft uses to describe software updates.

↑ Back to the top


Keywords: kb, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbexpertiseinter, kbsurveynew, kbbug

↑ Back to the top

Article Info
Article ID : 2930574
Revision : 1
Created on : 1/7/2017
Published on : 3/21/2014
Exists online : False
Views : 253