"Unable to authenticate your credentials" error when you try to connect to Microsoft Entra ID

Original product version:   Microsoft Entra ID, Cloud Services (Web roles/Worker roles), Microsoft Intune, Azure Backup, Office 365 User and Domain Management, Office 365 Identity Management
Original KB number:   2929554

Symptoms

When you try to connect to Microsoft Entra ID by using the Azure Active Directory module for Windows PowerShell, you receive the following error message:

Connect-MsolService : Unable to authenticate your credentials. Make sure that
your user name is in the format: <username>@<domain>. If this issue persists,
contact Support.

At line:1 char:1
+ Connect-MsolService
+ ~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : OperationStopped: (:) [Connect-MsolService], Mic
rosoftOnlineException
+ FullyQualifiedErrorId : 0x80048862,Microsoft.Online.Administration.Autom
ation.ConnectMsolService

Note

Azure AD and MSOnline PowerShell modules are deprecated as of March 30, 2024. To learn more, read the deprecation update. After this date, support for these modules are limited to migration assistance to Microsoft Graph PowerShell SDK and security fixes. The deprecated modules will continue to function through March, 30 2025.

We recommend migrating to Microsoft Graph PowerShell to interact with Microsoft Entra ID (formerly Azure AD). For common migration questions, refer to the Migration FAQ. Note: Versions 1.0.x of MSOnline may experience disruption after June 30, 2024.

Cause

This issue occurs if one of the following conditions is true:

  • You used an incorrect format when you entered your user name.
  • Your user account is enabled for Microsoft Entra multifactor authentication.

Resolution

Do one of the following, as appropriate for your situation.

Scenario 1: You used an incorrect format when you entered your user name

Use the following format when you enter your user name:

<user_name >@<domain>

For example, john@contoso.com is in the correct format. Entering john or contoso\john doesn't work.

Scenario 2: Your user account is enabled for Microsoft Entra multifactor authentication

If your user account is enabled for Microsoft Entra multifactor authentication, Microsoft doesn't currently support using the Azure Active Directory module for Windows PowerShell to connect to Microsoft Entra ID.

To perform administrative tasks by using the Azure Active Directory module for Windows PowerShell, use either of the following methods:

  • Disable Microsoft Entra multifactor authentication for the user account.
  • Use a different admin account that isn't enabled for Microsoft Entra multifactor authentication.

Contact us for help

If you have questions or need help, create a support request, or ask Azure community support. You can also submit product feedback to Azure feedback community.