Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

SetDefaultPrinter sets a wrong default printer in Windows


View products that this article applies to.

Symptoms

Assume that you have a computer that is running Windows 8.1, Windows RT 8.1, Windows Server 2012 R2, Windows 7 Service Pack 1 (SP1), or Windows Server 2008 R2 SP1. When a service on the computer impersonates a user and then calls SetDefaultPrinter to set a default printer, you find the default printer is set to a wrong printer rather than to the expected one.

↑ Back to the top


Cause

This issue occurs because when the impersonated user calls SetDefaultPrinter to set a default printer, some registry values may be set in the wrong user profile. These values will be set in the service account's profile rather than in the impersonated user's profile.

↑ Back to the top


Resolution

To resolve this issue in Windows RT 8.1, Windows 8.1, or Windows Server 2012 R2, install update rollup 2955164.

To resolve this issue in Windows 7 SP1 or Windows Server 2008 R2 SP1, install the hotfix that is described in this article.

Update information for Windows RT 8.1, Windows 8.1, and Windows Server 2012 R2

For more information about how to obtain this update rollup package, click the following article number to view the article in the Microsoft Knowledge Base:
2955164 Windows RT 8.1, Windows 8.1, and Windows Server 2012 R2 update rollup: May 2014

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix Download Available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix Download Available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows 7 SP1 or Windows Server 2008 R2 SP1. For more information about how to obtain a Windows 7 or Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To use the update in this package, you do not have to make any changes to the registry.

Restart requirement

You do not have to restart the computer after you apply this update.

Update replacement information

This update does not replace a previously released update.
File information
The global version of this update installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files

Windows 7 and Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
    VersionProductMilestoneService branch
    6.1.760
    1.22xxx
    Windows 7 and Windows Server 2008 R2SP1LDR
  • GDR service branches contain only those fixes that are widely released to address widespread, critical issues. LDR service branches contain hotfixes in addition to widely released fixes.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows 7 and for Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are critical to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 7 SP1
File nameFile versionFile sizeDateTimePlatform
Winspool.drv6.1.7601.22586320,51231-Jan-201402:01Not applicable
For all supported x64-based versions of Windows 7 SP1 and Windows Server 2008 R2 SP1
File nameFile versionFile sizeDateTimePlatform
Winspool.drv6.1.7601.22586442,88031-Jan-201402:42Not applicable
Winspool.drv6.1.7601.22586320,51231-Jan-201402:01Not applicable
For all supported IA64-based versions of Windows 7 SP1 and Windows Server 2008 R2 SP1
File nameFile versionFile sizeDateTimePlatform
Winspool.drv6.1.7601.22586863,74431-Jan-201401:47Not applicable
Winspool.drv6.1.7601.22586320,51231-Jan-201402:01Not applicable

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows 7 and Windows Server 2008 R2
Additional files for all supported x86-based versions of Windows 7 SP1
File propertyValue
File nameX86_b9be03775b174dcbd9a357e88c5df192_31bf3856ad364e35_6.1.7601.22586_none_d4e57e451da08e94.manifest
File versionNot applicable
File size711
Date (UTC)31-Jan-2014
Time (UTC)06:19
PlatformNot applicable
File nameX86_microsoft-windows-p..ting-spooler-client_31bf3856ad364e35_6.1.7601.22586_none_9575354790449c1a.manifest
File versionNot applicable
File size2,770
Date (UTC)31-Jan-2014
Time (UTC)02:34
PlatformNot applicable
Additional files for all supported x64-based versions of Windows 7 SP1 and Windows Server 2008 R2 SP1
File propertyValue
File nameAmd64_2f751eea09800b0fdfaa3a19b2746660_31bf3856ad364e35_6.1.7601.22586_none_ed2edb63ccede8e3.manifest
File versionNot applicable
File size715
Date (UTC)31-Jan-2014
Time (UTC)06:19
PlatformNot applicable
File nameAmd64_b9be03775b174dcbd9a357e88c5df192_31bf3856ad364e35_6.1.7601.22586_none_310419c8d5fdffca.manifest
File versionNot applicable
File size713
Date (UTC)31-Jan-2014
Time (UTC)06:19
PlatformNot applicable
File nameAmd64_e54176687630f48002d388b399aef792_31bf3856ad364e35_6.1.7601.22586_none_a41deea634a8b241.manifest
File versionNot applicable
File size1,070
Date (UTC)31-Jan-2014
Time (UTC)06:19
PlatformNot applicable
File nameAmd64_microsoft-windows-p..ting-spooler-client_31bf3856ad364e35_6.1.7601.22586_none_f193d0cb48a20d50.manifest
File versionNot applicable
File size2,774
Date (UTC)31-Jan-2014
Time (UTC)03:12
PlatformNot applicable
File nameX86_microsoft-windows-p..ting-spooler-client_31bf3856ad364e35_6.1.7601.22586_none_9575354790449c1a.manifest
File versionNot applicable
File size2,770
Date (UTC)31-Jan-2014
Time (UTC)02:34
PlatformNot applicable
Additional files for all supported IA64-based versions of Windows 7 SP1 and Windows Server 2008 R2 SP1
File propertyValue
File nameIa64_6d10e03d1e263fd57ee926acb9dc5d55_31bf3856ad364e35_6.1.7601.22586_none_72a696281488ce23.manifest
File versionNot applicable
File size1,068
Date (UTC)31-Jan-2014
Time (UTC)06:19
PlatformNot applicable
File nameIa64_microsoft-windows-p..ting-spooler-client_31bf3856ad364e35_6.1.7601.22586_none_9576d93d9042a516.manifest
File versionNot applicable
File size2,772
Date (UTC)31-Jan-2014
Time (UTC)02:18
PlatformNot applicable
File nameX86_microsoft-windows-p..ting-spooler-client_31bf3856ad364e35_6.1.7601.22586_none_9575354790449c1a.manifest
File versionNot applicable
File size2,770
Date (UTC)31-Jan-2014
Time (UTC)02:34
PlatformNot applicable

↑ Back to the top


Keywords: kb, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbexpertiseadvanced

↑ Back to the top

Article Info
Article ID : 2927901
Revision : 1
Created on : 1/7/2017
Published on : 5/13/2014
Exists online : False
Views : 291