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Slow startup of Modern Apps when RNDIS devices are connected


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Symptoms

Consider the following scenario:
  • You have a computer that is running Windows 8 or Windows 8.1.
  • You plug-in a USB device that is used for downloading information from Platform Builder to emulate a network connection.
  • You open any Modern App that is using a network connection (such as Skype, OneDrive, Bing, etc..)
In this scenario, the App takes long time to load (showing Skype login screen can take 10-60 seconds).

When connecting USB device to Windows 8 or Windows 8.1, it expose USB descriptors:  Class E0 SubClass 01 Protocol 03.
Windows choose to use the following built-in INF file and drivers:

Inf: WcelSvita.inf
Inf section: RNDIS.NT.5.1 
Driver files: rndismpx.sys and usb802.3x.sys
Version: 6.2.9200.16384 date 6/21/2006.

Note: The issue is not noticed on Modern Apps that run without a network connection.


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Cause

This issue may occur if the USB device is mapped to a incorrect RNDIS 5 based driver. If the underlying network device uses Remote NDIS (RNDIS) 5 drivers, you may experience slowness in loading the Modern Apps.


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Workaround

Upgrade the drivers to use RNDIS 6.x driver. Contact your devices Hardware Vendor on steps to receive the files/steps required to update the driver so it uses RNDIS 6.x driver.


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More Information

NDIS 5 was originally released in 2002 as part of Windows XP. Given the age of the technology and the availability of improved subsequent versions (e.g. NDIS 6 includes Enhanced Performance and Scalability http://msdn.microsoft.com/en-us/library/windows/hardware/ff548860(v=vs.85).aspx), NDIS 5.x has been deprecated and is superseded by NDIS 6.x.


Additional Information

To verify if your device is using RNDIS 5 driver, use the following steps:
  1. Open Device Manager from Control Panel and expand “Network Adapters.”
  2. Plug in your device and enable USB Tethering so that the device is detected as Remote NDIS based device.
  3. This should now create a Network Adapter named as “ [Your Device Name] Remote NDIS based [internet Sharing/network] Device.”
  4. Right-click the Adapter and select Properties.
  5. Select the Driver tab and then click Driver Details.
  6. You can see the driver files if the files are named usb8023x.sys and rndismpx.sys you are using RNDIS 5 Driver.

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Keywords: kb

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Article Info
Article ID : 2923775
Revision : 1
Created on : 1/7/2017
Published on : 6/30/2014
Exists online : False
Views : 430