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Windows Search does not work as expected or generates an error message in Windows 8.1


View products that this article applies to.

Symptoms

When you use the Search charm in Windows 8.1 to search for files or applications, the search process runs very slowly, or the search does not return search results from your computer hard disk or your OneDrive account.

If you try to manually start the Windows Search service, you receive the following error message:

Windows could not start the Windows Search service on Local Computer.

Error 2: The system cannot find the file specified.

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Cause

These problems may occur because of a third-party registry cleaner tool. Such tools can remove or corrupt registry values that are used by Windows Search.

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Resolution

Important Follow the steps in this section carefully. Serious problems might occur if you modify the registry incorrectly. Before you modify it, back up the registry for restoration in case problems occur.

To resolve this issue, you must delete certain registry entries. To do this, follow these steps:
  1. Open an elevated command prompt. To do this, use one of the following methods.
    If you are using a keyboard
    1. Press the Windows logo key+X.
    2. Click Command Prompt (Admin).
    If you are not using a keyboard
    1. On the Start screen, swipe in from the right side, and then tap or click cmd in the Search box.
    2. In the search results, locate and then press and hold or right-click Command Prompt, and then tap or click Run as Administrator.
    Note If you are not signed in by using an administrator account, you must enter the user name and password for an administrator account on the computer.

  2. Type regedit.exe, and then press Enter.
  3. If you are prompted for confirmation to allow changes to the registry, tap or click Yes.
  4. Click Find on the Edit menu.
  5. In the Find what field, type FileChangeClientConfigs, and then tap or click Find next.
  6. In the navigation pane, expand the FileChangeClientConfigs node by tapping or clicking the expand/collapse arrow.
  7. In the navigation pane under the FileChangeClientConfigs node, look for the entries that have names that consist of letters, numbers, braces, and hyphens.
  8. Select each entry by tapping or clicking it. In the details pane, look for a registry value that is named ScopeToMonitor in the Name column. Then, do one of the following:
    1. If there is a value that is named ScopeToMonitor, leave that registry entry in the navigation pane unchanged, and go to the next entry.
    2. If there is no value that is named ScopeToMonitor, press and hold or right-click the registry entry in the navigation pane, and then select Delete.
  9. Close Registry Editor to return to the Start screen.
  10. Swipe in from the right side, select the Settings charm, and then tap or click Restart.

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Status

Microsoft has confirmed that this is a bug in the Microsoft products that are listed in the "Applies to" section.

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Keywords: kbsurveynew, kbexpertiseinter, kbfix, kb

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Article Info
Article ID : 2923592
Revision : 1
Created on : 1/7/2017
Published on : 2/25/2015
Exists online : False
Views : 187