Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

ACC2000: Unable to Import Excel Spreadsheets and HTML Files


View products that this article applies to.

This article was previously published under Q292269
Novice: Requires knowledge of the user interface on single-user computers.

This article applies to a Microsoft Access database (.mdb) and to a Microsoft Access project (.adp).

For a Microsoft ACC97 version of this article, see 303804 (http://support.microsoft.com/kb/303804/EN-US/ ) .
For a Microsoft ACC2002 version of this article, see 303805 (http://support.microsoft.com/kb/303805/EN-US/ ) .

↑ Back to the top


Symptoms

You are unable to import Microsoft Excel Spreadsheets and HTML files. When you use the Import Wizard to import a Microsoft Excel spreadsheet or a Hypertext Markup Language (HTML) file, you see a message in the status bar that says "Import Spreadsheet Wizard" or "Import HTML Wizard," but the wizard is not visible. If you quit Microsoft Access and open the Task Manager, the Task Manager shows Access as still running.

↑ Back to the top


Cause

This behavior can occur because you do not have the correct version of Accwiz.dll registered on your computer.

↑ Back to the top


Resolution

To resolve this behavior, register the correct version of Accwiz.dll. For Access 2000, the correct version begins with the number 9. For example, the version might be 9.0.0.2607. To register the Accwiz.dll file, follow these steps:

NOTE: The following steps require that you have Regsvr32.exe installed on your computer. For additional information about how to obtain Regsvr32.exe, click the article number below to view the article in the Microsoft Knowledge Base:
267279� ACC2000: Regsvr32.exe Available in Download Center
NOTE: Because there are several versions of Microsoft Windows, the following steps may be different on your computer. If they are, see your product documentation to complete these steps.
  1. Click Start, point to Search, and then click Files or Folders.
  2. In the Search for files or folders named box, type Accwiz.dll, and then click Search now.
  3. In the Search Results pane, right-click the first file listed, and then click Properties on the shortcut menu.
  4. Click the Version tab, note the file version for that file and the folder in which it was found, and then click Cancel.
  5. Repeat steps 3 and 4 for all files listed in the Search Results pane so that you can identify the folder containing the version of Accwiz.dll that you need to register, and then close the Search Results dialog box.
  6. Click Start, click Run, and then type regsvr32 <path>\Accwiz.dll in the Open box, where <path> is the path of the folder containing the correct Accwiz.dll version. Press ENTER.
This process registers the correct version of Accwiz.dll and allows the import process to proceed as it should.

↑ Back to the top


More information

The table below shows what the version of Accwiz.dll should start with for various versions of Access and an example of the complete version number.
    Access version     Accwiz.dll begins with     Example of version number
    --------------     ----------------------     -----------
    Access 2002        10                         10.0.2627.1
    Access 2000        9                          9.0.0.2607
    Access 97          8                          8.0.0.4323
				

↑ Back to the top


Keywords: KB292269, kbprb

↑ Back to the top

Article Info
Article ID : 292269
Revision : 2
Created on : 6/25/2004
Published on : 6/25/2004
Exists online : False
Views : 306