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Sppsvc.exe crashes when you activate Windows 8.1 in offline scenarios


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have a computer that is running Windows 8.1 or Windows Server 2012 R2.
  • You run the "slmgr /ipk" command to apply a retail key and the command is successfully completed.
  • You run the "slmgr /ato" command to activate the computer.
In this situation, the Microsoft Software Protection Platform Service process (sppsvc.exe) crashes and the activation fails. Additionally, you receive the following error message:
Error: 0xC002001B On a computer running Microsoft Windows non-core edition, run 'slui.exe 0x2a 0xC002001B' to display the error text.

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Cause

This issue occurs because a null string was created in the token activation issuance license (TAIL).

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Resolution

To resolve this issue, install update rollup 2928680, or install the hotfix that is described in this article. 

Update information

For more information about how to obtain update rollup 2928680, click the following article number to view the article in the Microsoft Knowledge Base:
2928680 Windows RT 8.1, Windows 8.1, and Windows Server 2012 R2 update rollup: March 2014

Hotfix information

A supported hotfix is available from Microsoft Support. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, go to the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows 8.1 or Windows Server 2012 R2 installed.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any previously released hotfix.

File information
The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.

Windows 8.1 and Windows Server 2012 R2 file information and notes

Important Windows 8.1 and Windows Server 2012 R2 hotfixes are included in the same packages. However, only "Windows Blue RTM" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows Blue RTM" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, milestone (RTM,SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.

    VersionProductMilestoneService branch
    6.3.960 0.16 xxxWindows 8.1 and Windows Server 2012 R2RTMGDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows 8.1" section. MUM, MANIFEST, and the associated security catalog (.cat) files, are very important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For Windows RT 8.1
File nameFile versionFile sizeDateTimePlatform
Security-spp-ppdlic.xrm-msNot Applicable4,54221-Dec-201309:30Not Applicable
Sppmig.dll6.3.9600.16384108,54422-Aug-201303:06Not Applicable
Sppsvc.exe6.3.9600.164973,180,09621-Dec-201309:32Not Applicable
For all supported x86-based versions of Windows 8.1
File nameFile versionFile sizeDateTimePlatform
Security-spp-ppdlic.xrm-msNot Applicable4,54221-Dec-201311:51Not Applicable
Sppmig.dll6.3.9600.16384135,68022-Aug-201303:55x86
Sppsvc.exe6.3.9600.164975,251,22421-Dec-201312:06x86
For all supported x64-based versions of Windows 8.1 and of Windows Server 2012 R2
File nameFile versionFile sizeDateTimePlatform
Security-spp-ppdlic.xrm-msNot Applicable4,54221-Dec-201314:44Not Applicable
Sppmig.dll6.3.9600.16384132,60822-Aug-201311:23x64
Sppsvc.exe6.3.9600.164976,353,96021-Dec-201314:51x64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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Additional file information

Additional file information for Windows 8.1 and Windows Server 2012 R2

Additional files for Windows RT 8.1
File nameArm_4e2c0016715a5125b75362d0aa52dd05_31bf3856ad364e35_6.3.9600.16497_none_6269619c90ad2fbd.manifest
File versionNot Applicable
File size700
Date (UTC)23-Dec-2013
Time (UTC)02:41
File nameArm_microsoft-windows-security-spp_31bf3856ad364e35_6.3.9600.16497_none_aefbc12f3c8f0c07.manifest
File versionNot Applicable
File size26,098
Date (UTC)23-Dec-2013
Time (UTC)02:41
Additional files for all supported x86-based versions of Windows 8.1
File nameX86_b39e7500db7a5f792e000bb13fba9177_31bf3856ad364e35_6.3.9600.16497_none_17ef30f3be05be36.manifest
File versionNot Applicable
File size700
Date (UTC)23-Dec-2013
Time (UTC)02:41
File nameX86_microsoft-windows-security-spp_31bf3856ad364e35_6.3.9600.16497_none_aef94ed73c91ed41.manifest
File versionNot Applicable
File size26,098
Date (UTC)23-Dec-2013
Time (UTC)02:41
Additional files for all supported x64-based versions of Windows 8.1 and of Windows Server 2012 R2
File nameAmd64_4c8399587361568aca0dd97e2e95aed1_31bf3856ad364e35_6.3.9600.16497_none_b8f170b9600ef1eb.manifest
File versionNot Applicable
File size704
Date (UTC)23-Dec-2013
Time (UTC)02:43
File nameAmd64_f78cc8db8667c7ee7be6173f9800f500_31bf3856ad364e35_6.3.9600.16497_none_80281a66c58709f5.manifest
File versionNot Applicable
File size704
Date (UTC)23-Dec-2013
Time (UTC)02:43
File nameAmd64_microsoft-windows-security-spp_31bf3856ad364e35_6.3.9600.16497_none_0b17ea5af4ef5e77.manifest
File versionNot Applicable
File size26,104
Date (UTC)23-Dec-2013
Time (UTC)02:43

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References

Learn about the terminology that Microsoft uses to describe software updates.

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Keywords: kb, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbexpertiseinter

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Article Info
Article ID : 2921501
Revision : 1
Created on : 1/7/2017
Published on : 3/11/2014
Exists online : False
Views : 450