Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

A Lync Room System device cannot sign in automatically when a user restarts the device


View products that this article applies to.

Symptoms

Assume that Microsoft Lync Room System (LRS) is deployed in an organization. A user in the organization restarts the Lync Room System. In this situation, LRS is locked and the user is prompted to enter a password on the LRS console. However, the system cannot be unlocked by using either the user's password or an administrator password. To use the LRS device, an administrator must restore the device to factory settings, and then enter the password. 

↑ Back to the top


Cause

This issue occurs because the LRS software product key is automatically renewed in meeting mode. However, the key is not persisted by the system’s Enhanced Write Filter. So, the CryptUnprotectData API fails. Then, LRS code ignores the failure errors during decryption and creates blank values to the local LRS user’s password and the Lync 2013 password. Therefore, both of the passwords are lost and the LRS device cannot sign in automatically.

↑ Back to the top


Resolution

To resolve this issue, install the following update:
2920616 Description of the Lync Room System update: January 2014

Note The update prevents the password from losing but cannot recover the lost password. Therefore, when this issue occurs, an administrator must restore LRS to factory settings, and then install the update. 

↑ Back to the top


Keywords: kbqfe, kbfix, kbsurveynew, kbexpertisebeginner, kb

↑ Back to the top

Article Info
Article ID : 2920614
Revision : 1
Created on : 1/7/2017
Published on : 3/17/2014
Exists online : False
Views : 322