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An application cannot establish a connection to its required destination services in Windows 8.1


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have a computer that is running Windows 8.1.
  • The computer is using a forwarding IP address, or the Weak Host model is enabled.
  • You run an application that requires a network socket connection to services that are running on the same computer or on a different computer.

In this scenario, the application may not establish a connection to its required destination services.

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Cause

This problem occurs when the TCP/IP driver incorrectly selects the loopback IP address (127.0.0.1) as the best physical interface for the destination services.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft Support. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, go to the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows 8.1 installed.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any previously released hotfix.

File information
The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.

Windows 8.1 file information and notes

Important Windows 8.1 and Windows Server 2012 R2 hotfixes are included in the same packages. However, only "Windows Blue RTM" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows Blue RTM" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, milestone (RTM,SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.

    VersionProductMilestoneService branch
    6.3.960 0.16 xxxWindows 8.1RTMGDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows 8.1" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 8.1
File nameFile versionFile sizeDateTimePlatform
Fwpkclnt.sys6.3.9600.16384286,04822-Aug-201305:20x86
Tcpip.sys6.3.9600.164961,883,99220-Dec-201308:30x86
For all supported x64-based versions of Windows 8.1
File nameFile versionFile sizeDateTimePlatform
Fwpkclnt.sys6.3.9600.16384428,89622-Aug-201312:34x64
Tcpip.sys6.3.9600.164962,544,47220-Dec-201310:15x64
For all supported ARM-based versions of Windows 8.1
File nameFile versionFile sizeDateTimePlatform
Fwpkclnt.sys6.3.9600.16384278,88822-Aug-201303:52Not applicable
Tcpip.sys6.3.9600.164961,753,44020-Dec-201306:09Not applicable

Additional file information for Windows 8.1

Additional files for all supported x86-based versions of Windows 8.1
File nameX86_1b1a80709afbb477734ba933a8dab3ef_31bf3856ad364e35_6.3.9600.16496_none_d39a7943fa78ed49.manifest
File versionNot applicable
File size702
Date (UTC)20-Dec-2013
Time (UTC)17:58
SHA-1 hashNot applicable
MD5 hashNot applicable
File nameX86_microsoft-windows-tcpip-binaries_31bf3856ad364e35_6.3.9600.16496_none_47b50967820621fa.manifest
File versionNot applicable
File size3,883
Date (UTC)20-Dec-2013
Time (UTC)17:58
SHA-1 hashNot applicable
MD5 hashNot applicable
Additional files for all supported x64-based versions of Windows 8.1
File nameAmd64_5af7d55a0ad3cff77747e3d5c91afee2_31bf3856ad364e35_6.3.9600.16496_none_a26f6b05fceb238b.manifest
File versionNot applicable
File size706
Date (UTC)20-Dec-2013
Time (UTC)17:37
SHA-1 hashNot applicable
MD5 hashNot applicable
File nameAmd64_microsoft-windows-tcpip-binaries_31bf3856ad364e35_6.3.9600.16496_none_a3d3a4eb3a639330.manifest
File versionNot applicable
File size3,887
Date (UTC)20-Dec-2013
Time (UTC)17:37
SHA-1 hashNot applicable
MD5 hashNot applicable
Additional files for all supported ARM-based versions of Windows 8.1
File nameArm_f115c76564340a50952711625988be75_31bf3856ad364e35_6.3.9600.16496_none_731ce078c036118e.manifest
File versionNot applicable
File size702
Date (UTC)20-Dec-2013
Time (UTC)18:00
SHA-1 hashNot applicable
MD5 hashNot applicable
File nameArm_microsoft-windows-tcpip-binaries_31bf3856ad364e35_6.3.9600.16496_none_47b77bbf820340c0.manifest
File versionNot applicable
File size3,883
Date (UTC)20-Dec-2013
Time (UTC)18:00
SHA-1 hashNot applicable
MD5 hashNot applicable

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

When a computer is in this condition, the establishment of all successive network connections (including ping) to a particular destination IP address is unsuccessful. Flushing the Address Resolution Protocol (ARP) cache may temporarily resolve this problem. To flush the ARP cache, run the following command:

netsh interface ip delete arpcahe

After the TCP/IP driver incorrectly selects the loopback IP address, the address is cached in the TCP/IP destination path cache. The TCP/IP stack continues to select the loopback address for all successive network connections. This causes these connections to be unsuccessful. A destination cache dump file may show the loopback address as being selected (Source field) for a destination on a non-loopback or physical interface. To perform a destination cache dump file, run the following command:

netsh interface ipv4 show destinationcache level=verbose

The scenarios in which this problem may occur are as follows:
  • The computer uses a forwarding IP address or has the Weak Host (send/receive) model enabled and temporarily sets the SkipAsSource field on a physical interface.
  • The computer uses a forwarding IP address or has the Weak Host (send/receive) model enabled. Under certain network stress conditions, a race condition may occur in the TCP/IP path computation.
  • The computer uses a forwarding IP address, has the Weak Host (send/receive) model enabled, or has an additional IP address assigned on the loopback interface. In this case, the TCP/IP stack may incorrectly mark a computed path as unconstrained. This leads to address lookup failures. It is a race condition and may occur when the IP address is temporarily disabled and then re-enabled.

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References

See the terminology  that Microsoft uses to describe software updates for more information.

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Keywords: kb, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbexpertiseinter, kbsurveynew, kbbug

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Article Info
Article ID : 2920546
Revision : 1
Created on : 1/7/2017
Published on : 2/12/2014
Exists online : False
Views : 189