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Large files cannot be replicated by the DFSR service in Windows Server 2012


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You use the Distributed File System Replication (DFSR) service in a Windows Server 2012-based domain environment.
  • You have a Distributed File System (DFS) replication group in the domain environment.
  • You use the DFSR service to replicate files in the DFS replication group. The sizes of some files are large. For example, the size of a file is 10 gigabytes (GB).

In this scenario, the files that are large cannot be replicated.

Note This problem typically occurs when the replication connection is opened and then closed frequently. This might be caused by a scheduled replication job or unreliable network connectivity.In the DFSR debug log, there is information that states the partial copy of the replicated file is saved and then dropped.

Additionally, the following information is logged in the DFSR debug log:

datetime 2376 RDCX 882 [WARN] Rdc::SeedFile::Initialize (Ignored) Abandoning candidate file.
uid:{C5B5CBC3-EAFF-4C3B-9F5F-BC5C27EC44A8}-v103 gvsn:{C5B5CBC3-EAFF-4C3B-9F5F-BC5C27EC44A8}-v104 fileName:
ri2k3-dc1.vhd csId:{A739B084-9C47-4514-97DB-D8E4344D6438}
Candidate(uid:{C5B5CBC3-EAFF-4C3B-9F5F-BC5C27EC44A8}-v103
gvsn:{C5B5CBC3-EAFF-4C3B-9F5F-BC5C27EC44A8}-v104
fileName:104-{C5B5CBC3-EAFF-4C3B-9F5F-BC5C27EC44A8}-v103-{C5B5CBC3-EAFF-4C3B-9F5F-BC5C27EC44A8}-v104-Partial.frx)
+ [Error:9048(0x2358) StageReader::Serialize staging.cpp:529 2376 C The compressed data is invalid]
+ [Error:9048(0x2358) Rdc::StagingClosure::Run rdc.cpp:3947 2376 C The compressed data is invalid]
+ [Error:9048(0x2358) Rdc::Common::StageFile rdc.cpp:3574 2376 C The compressed data is invalid]
+ [Error:9048(0x2358) StreamToIndex rdc.cpp:529 2376 C The compressed data is invalid]
+ [Error:9048(0x2358) SignatureGenerator rdc.cpp:279 2376 C The compressed data is invalid]
+ [Error:9048(0x2358) XpressUncompressReader::Read xpressstreams.cpp:1379 2376 C The compressed data is invalid]
+ [Error:9048(0x2358) XpressUncompressReader::Read xpressstreams.cpp:1323 2376 C The compressed data is invalid

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Cause

This problem occurs because DFSR considers the partial copy of the replicated file as invalid. When a large file cannot be replicated in one session, DFSR saves a partial copy of the replicated file so that the replication process can continue from where it stopped. Because the partial copy of the file is considered invalid by DFSR, DFSR has to re-start the replication process. However, the replication connection is never opened long enough for the replication process to be completed. Therefore, large files cannot be replicated.

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Resolution

To resolve this problem, apply this hotfix. After the hotfix is applied, replication resumes a partial file copy where it left off instead of starting over from the beginning.

Hotfix information

A supported hotfix is available from Microsoft Support. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, go to the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows Server 2012 installed.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any previously released hotfix.

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File information
The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.

Windows 8 and Windows Server 2012 file information and notes

Important Windows 8 and Windows Server 2012 hotfixes are included in the same packages. However, only "Windows 8" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 8" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, milestone (RTM,SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.

    VersionProductMilestoneService branch
    6.2.920 0.16 xxxWindows 8 and Windows Server 2012RTMGDR
    6.2.920 0.20 xxxWindows 8 and Windows Server 2012RTMLDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows 8 and Windows Server 2012" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2012
File nameFile versionFile sizeDateTimePlatform
Dfsrprovs.mofNot Applicable75,76125-Jul-201220:12Not Applicable
Dfsrress.dll6.2.9200.163842,04826-Jul-201202:33x64
Dfsrs.exe6.2.9200.208994,724,73619-Dec-201300:24x64

Additional file information

Additional file information for Windows Server 2012

Additional files for all supported x64-based versions of Windows Server 2012
File nameAmd64_2beae9088974fa54abf8919396ec92cd_31bf3856ad364e35_6.2.9200.20899_none_f6ff7a3e18a75efe.manifest
File versionNot Applicable
File size712
Date (UTC)19-Dec-2013
Time (UTC)23:28
PlatformNot Applicable
File nameAmd64_microsoft-windows-dfsr-core-serveronly_31bf3856ad364e35_6.2.9200.20899_none_f6d92e444aacb376.manifest
File versionNot Applicable
File size37,695
Date (UTC)19-Dec-2013
Time (UTC)23:28
PlatformNot Applicable

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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References

Learn about the terminology Microsoft uses to describe software updates.

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Keywords: kb, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbexpertiseinter, kbsurveynew, kbbug

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Article Info
Article ID : 2920468
Revision : 1
Created on : 1/7/2017
Published on : 2/12/2014
Exists online : False
Views : 170