Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

The DNS service takes a long time to start on a DNS server that is running Windows Server 2012


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have a Domain Name System (DNS) server that is running Windows Server 2012.
  • You have hundreds of Active Directory-Integrated DNS Zones configured on the DNS server.
  • The domain naming master server is temporally down.
  • The DNS service is started.

In this scenario, it may take a long time (for example, several hours) for the DNS service to restart.

↑ Back to the top


Cause

For each zone to be loaded, the DNS Server service tries to connect to the domain controller that has the Active Directory domain naming operations master role and waits until the TCP connection attempt times out. By default, it takes about 21 seconds for each call to fail. If there are hundreds of zones configured, the time-out for each such connection accumulates, and it takes a long time for the DNS service to restart.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft Support. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, go to the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows Server 2012 installed.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any previously released hotfix.

File information
The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.

Windows Server 2012 file information and notes

Important Windows 8 and Windows Server 2012 hotfixes are included in the same packages. However, only "Windows 8" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 8" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, milestone (RTM,SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.

    VersionProductMilestoneService branch
    6.2.920 0.20 xxxWindows Server 2012RTMLDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2012" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2012
File nameFile versionFile sizeDateTimePlatform
Cache.dnsNot applicable3,19802-Jun-201214:30Not applicable
Dns.exe6.2.9200.208981,534,46417-Dec-201300:50x64
Dnsserver.events.xmlNot applicable60902-Jun-201214:30Not applicable

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


Additional file information

Additional file information for Windows Server 2012

Additional files for all supported x64-based versions of Windows Server 2012
File nameAmd64_8a2f9e3ae4c9cb574e025b9e0e3e1d10_31bf3856ad364e35_6.2.9200.20898_none_716a154ef64e00a7.manifest
File versionNot applicable
File size710
Date (UTC)19-Dec-2013
Time (UTC)11:43
PlatformNot applicable
File nameAmd64_microsoft-windows-dns-server-service_31bf3856ad364e35_6.2.9200.20898_none_a7526279797ae4b5.manifest
File versionNot applicable
File size184,291
Date (UTC)17-Dec-2013
Time (UTC)03:47
PlatformNot applicable
File namePackage_1_for_kb2917302~31bf3856ad364e35~amd64~~6.2.1.0.mum
File versionNot applicable
File size1,832
Date (UTC)19-Dec-2013
Time (UTC)11:43
PlatformNot applicable
File namePackage_for_kb2917302_rtm~31bf3856ad364e35~amd64~~6.2.1.0.mum
File versionNot applicable
File size1,460
Date (UTC)19-Dec-2013
Time (UTC)11:43
PlatformNot applicable

↑ Back to the top


References

See the terminology Microsoft uses to describe software updates for more information.

↑ Back to the top


Keywords: kb, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbexpertiseinter, kbsurveynew, kbbug

↑ Back to the top

Article Info
Article ID : 2917302
Revision : 1
Created on : 1/7/2017
Published on : 5/14/2014
Exists online : False
Views : 218