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Office 365 authentication fails when a client user is outside the corporate network in Windows Server 2012 R2


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have a Windows Server 2012 R2-based server that has Active Directory Federation Services (AD FS) 3.0 installed.
  • You have Windows 7-based or Windows 8-based client computers.
  • The value of the NtlmOnlySupportedClientAtProxy property is set to TRUE on the server.
  • You try to edit or save a Microsoft Office document while you are using a client computer that is outside the corporate network.
In this scenario, Microsoft Office 365 authentication fails. 

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Cause

This issue occurs because the AD FS proxy code looks for a "WWWAuthenticate" header in the Security Token Service (STS) response headers instead of in the request headers.

The Office 365 authentication component requests the AD FS proxy to use "negotiate" as the authentication mechanism between the Windows 7-based or Windows 8-based client computers. A WWWAuthenticate header is added to the request header. However, the proxy code looks for the header in the STS response headers instead of in the request headers. Therefore, the header cannot be found when the server tries to authenticate the client computer. Windows 7-based and Windows 8-based client computers cannot perform the Windows Challenge/Response (NTLM) authentication.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix Download Available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix Download Available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2012 R2.

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.
File information
The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.





Windows Server 2012 R2 file information notes
Important Windows 8.1 hotfixes and Windows Server 2012 R2 hotfixes are included in the same packages. However, only "Windows 8.1" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 8.1" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:

    VersionProductMilestoneService branch
    6.3.960 0.16 xxxWindows Server 2012 R2RTMGDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2012 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2012 R2
File nameFile versionFile sizeDateTimePlatform
Microsoft.identityserver.proxyservice.exe6.3.9600.1647763,48827-Nov-201315:33x86
Microsoft.identityserver.proxyservice.exe.configNot applicable1,06718-Jun-201314:55Not applicable
Microsoft.identityserver.webhost.dll6.3.9600.16392172,03231-Aug-201314:23x86


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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
Additional file information

Additional file information for Windows Server 2012 R2

Additional files for all supported x64-based versions of Windows Server 2012 R2
File propertyValue
File nameAmd64_01f5ce74bdcbc4589be5b7ccbd393d70_31bf3856ad364e35_6.3.9600.16477_none_efe8eb19b27435c2.manifest
File versionNot applicable
File size710
Date (UTC)28-Nov-2013
Time (UTC)01:03
File nameAmd64_b08f1d804fb2ba52c1a39f780276f717_31bf3856ad364e35_6.3.9600.16477_none_95426249afcc97f7.manifest
File versionNot applicable
File size705
Date (UTC)28-Nov-2013
Time (UTC)01:03
File nameMsil_microsoft.identityserver.proxyservice_31bf3856ad364e35_6.3.9600.16477_none_46ee2d31e9308eb5.manifest
File versionNot applicable
File size4,764
Date (UTC)27-Nov-2013
Time (UTC)16:14
File nameMsil_microsoft.identityserver.webhost_31bf3856ad364e35_6.3.9600.16477_none_7926ccd9e1870342.manifest
File versionNot applicable
File size3,334
Date (UTC)28-Nov-2013
Time (UTC)01:03

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Keywords: kb, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbexpertiseadvanced

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Article Info
Article ID : 2914096
Revision : 1
Created on : 1/7/2017
Published on : 1/15/2014
Exists online : False
Views : 220