Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

IGMP host receives duplicate multicast packets when you have more than one Windows Server 2008 SP2 server that is configured as an IGMP router


View products that this article applies to.

Symptoms

Assume that you have more than one Windows Server 2008 SP2 Routing and Remote Access service (RRAS) server that is configured as an IGMP router in an environment. When a multicast application in the environment sends multicast packets from one side of the IGMP router, multicast clients on the other side of the IGMP router receive duplicate multicast packets.

↑ Back to the top


Cause

This issue occurs because both a non-querier RRAS server and the querier RRAS server are forwarding the IGMP packets.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running the following operating system:
  • Windows Server 2008 Service Pack 2 (SP2)
For more information about how to obtain a Windows Vista service pack, click the following article number to view the article in the Microsoft Knowledge Base:

935791 How to obtain the latest Windows Vista service pack

For more information about how to obtain a Windows Server 2008 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

968849 How to obtain the latest service pack for Windows Server 2008

Registry information

To apply this hotfix, you do not have to make any changes to the registry.

Restart requirement

When you apply this hotfix, you must restart the computer if the RRAS server is running. If the RRAS server that is configured as an IGMP router is in a stopped state, you do not have to restart the computer.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.
File information
The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2008 file information notes
Important Windows Vista hotfixes and Windows Server 2008 hotfixes are included in the same packages. However, only "Windows Vista" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows Vista" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.
    VersionProductSR_LevelService branch
    6.0.600 2.23xxxWindows Server 2008SP2LDR
  • Service Pack 1 is integrated into the release version of Windows Server 2008. Therefore, RTM milestone files apply only to Windows Vista. RTM milestone files have a 6.0.0000.xxxxxx version number.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 and for Windows Vista" section. MUM files and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Server 2008
File nameFile versionFile sizeDateTimePlatform
Igmpagnt.dll6.0.6002.2328012,28827-Nov-201302:47x86
Igmpv2.dll6.0.6002.23280162,30427-Nov-201302:47x86
Iprip2.dll6.0.6002.23280105,47227-Nov-201302:48x86
Mcastmib.dll6.0.6002.2328016,38427-Nov-201302:48x86
Ripagnt.dll6.0.6002.2328020,99227-Nov-201302:49x86
For all supported x64-based versions of Windows Server 2008
File nameFile versionFile sizeDateTimePlatform
Igmpagnt.dll6.0.6002.2328015,36027-Nov-201303:33x64
Igmpv2.dll6.0.6002.23280184,32027-Nov-201303:33x64
Iprip2.dll6.0.6002.23280116,22427-Nov-201303:33x64
Mcastmib.dll6.0.6002.2328019,96827-Nov-201303:33x64
Ripagnt.dll6.0.6002.2328024,06427-Nov-201303:35x64

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Server 2008

Additional files for all supported x86-based versions of Windows Server 2008
File propertyValue
File nameX86_ab8544e84db591167a57a57cba4802dc_31bf3856ad364e35_6.0.6002.23280_none_dffb0b77aff96eff.manifest
File versionNot applicable
File size707
Date (UTC)27-Nov-2013
Time (UTC)08:09
PlatformNot applicable
File nameX86_microsoft-windows-rasroutingprotocols_31bf3856ad364e35_6.0.6002.23280_none_72932fc38d3e0c5a.manifest
File versionNot applicable
File size99,048
Date (UTC)27-Nov-2013
Time (UTC)03:29
PlatformNot applicable
Additional files for all supported x64-based versions of Windows Server 2008
File propertyValue
File nameAmd64_f702bd573a6603eaf1b1227a802d1c3b_31bf3856ad364e35_6.0.6002.23280_none_ae4139cfe9dd179d.manifest
File versionNot applicable
File size711
Date (UTC)27-Nov-2013
Time (UTC)08:09
PlatformNot applicable
File nameAmd64_microsoft-windows-rasroutingprotocols_31bf3856ad364e35_6.0.6002.23280_none_ceb1cb47459b7d90.manifest
File versionNot applicable
File size99,078
Date (UTC)27-Nov-2013
Time (UTC)04:25
PlatformNot applicable

↑ Back to the top


Keywords: kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbexpertiseadvanced, kb

↑ Back to the top

Article Info
Article ID : 2913816
Revision : 1
Created on : 1/7/2017
Published on : 1/15/2014
Exists online : False
Views : 181